]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- added missing BR: autoconf, automake
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 Name:           kernel-misc-fuse
10 Summary:        Filesystem in Userspace
11 Summary(pl):    System plików w przestrzeni u¿ytkownika
12 Version:        1.1
13 %define         _rel    3
14 Release:        %{_rel}@%{_kernel_ver_str}
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
18 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
19 Patch0:         %{name}-configure.in.patch
20 URL:            http://sourceforge.net/projects/avf
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %if %{with kernel} && %{with dist_kernel}
24 BuildRequires:  kernel-module-build
25 %endif
26 %{?with_dist_kernel:%requires_releq_kernel_up}
27 BuildRequires:  rpmbuild(macros) >= 1.153
28 Requires(post,postun):  /sbin/depmod
29 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 FUSE (Filesystem in Userspace) is a simple interface for userspace
33 programs to export a virtual filesystem to the Linux kernel. FUSE also
34 aims to provide a secure method for non privileged users to create and
35 mount their own filesystem implementations.
36
37 %description -l pl
38 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
39 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
40 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
41 montowania w³asnych implementacji systemów plików przez zwyk³ych
42 (nieuprzywilejowanych) u¿ytkowników.
43
44 %package -n kernel-smp-misc-fuse
45 Summary:        Filesystem in Userspace
46 Summary(pl):    System plików w przestrzeni u¿ytkownika
47 Release:        %{_rel}@%{_kernel_ver_str}
48 License:        GPL v2
49 Group:          Applications/System
50 %{?with_dist_kernel:%requires_releq_kernel_up}
51 Requires(post,postun):  /sbin/depmod
52
53 %description -n kernel-smp-misc-fuse
54 FUSE (Filesystem in Userspace) is a simple interface for userspace
55 programs to export a virtual filesystem to the Linux kernel. FUSE also
56 aims to provide a secure method for non privileged users to create and
57 mount their own filesystem implementations.
58
59 %description -n kernel-smp-misc-fuse -l pl
60 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
61 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
62 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
63 montowania w³asnych implementacji systemów plików przez zwyk³ych
64 (nieuprzywilejowanych) u¿ytkowników.
65
66 %package -n libfuse
67 Summary:        Shared library for Filesytem in Userspace
68 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
69 Group:          Applications/System
70 Release:        %{_rel}
71
72 %description -n libfuse
73 Shared library for Filesytem in Userspace
74
75 %description -n libfuse -l pl
76 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
77
78 %package -n libfuse-devel
79 Summary:        Filesytem in Userspace - Development header fiels and libraries
80 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
81 Group:          Development/Libraries
82 Release:        %{_rel}
83 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
84
85 %description -n libfuse-devel
86 Libfuse library header files.
87
88 %description -n libfuse-devel -l pl
89 Libfuse biblioteki nag³ówkowe dla programistów.
90
91 %package -n libfuse-static
92 Summary:        Filesytem in Userspace - static libraries
93 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
94 Group:          Development/Libraries
95 Release:        %{_rel}
96 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
97
98 %description -n libfuse-static
99 Static libfuse libraries.
100
101 %description -n libfuse-static -l pl
102 Statyczne biblioteki libfuse
103
104 %package -n fusermount
105 Summary:        Filesytem in Userspace utilities
106 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
107 Group:          Applications/System
108 Release:        %{_rel}
109
110 %description -n fusermount
111 Filesytem in Userspace utilities. It provide a secure method for non
112 privileged users to create and mount their own filesystem implementations. 
113
114 %description -n fusermount -l pl
115 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
116 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %prep
122 %setup -q -n fuse-%{version}
123 %patch0 -p1
124
125 %build
126 %{__aclocal}
127 %{__autoconf}
128 %{__automake}
129 %configure \
130     --enable-lib \
131     --enable-util \
132     --with-kernel=%{_kernelsrcdir}
133
134 %if %{with kernel}
135 cd kernel
136 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
137     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
138         exit 1
139     fi
140     rm -rf include
141     install -d include/{linux,config}
142     ln -sf %{_kernelsrcdir}/config-$cfg .config
143     ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
144     ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
145     touch include/config/MARKER
146     %{__make} -C %{_kernelsrcdir} clean modules \
147         EXTRA_CFLAGS="-I../include -DFUSE_VERSION='1.1'" \
148         RCS_FIND_IGNORE="-name '*.ko' -o" \
149         M=$PWD O=$PWD \
150         %{?with_verbose:V=1}
151     mv fuse.ko fuse-$cfg.ko
152 done
153 cd -
154 %endif
155
156 cd lib
157 for f in fuse.c fuse_mt.c helper.c mount.c; do
158 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
159 done
160 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
161 cd -
162
163 %{?with_userspace:%{__make} -C util}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
169
170 %if %{with userspace}
171 cd util
172 install fusermount $RPM_BUILD_ROOT%{_bindir}/
173 cd -
174 %endif
175
176 %if %{with kernel}
177 cd kernel
178 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
179 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
180         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
181 %if %{with smp} && %{with dist_kernel}
182 install fuse-smp.ko \
183         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
184 %endif
185 cd -
186 %endif
187
188 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}
189 cd lib
190 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
191 cd -
192
193 %post
194 %depmod %{_kernel_ver}
195
196 %postun
197 %depmod %{_kernel_ver}
198
199 %post -n kernel-smp-misc-fuse
200 %depmod %{_kernel_ver}
201
202 %postun -n kernel-smp-misc-fuse
203 %depmod %{_kernel_ver}
204
205 %if %{with kernel}
206 %files
207 %defattr(644,root,root,755)
208 %doc README NEWS ChangeLog AUTHORS
209 %doc patch/
210 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
211
212 %if %{with smp} && %{with dist_kernel}
213 %files -n kernel-smp-misc-fuse
214 %defattr(644,root,root,755)
215 %doc README NEWS ChangeLog AUTHORS
216 %doc patch/
217 /lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko*
218 %endif
219 %endif
220
221 %if %{with userspace}
222 %files -n fusermount
223 %defattr(644,root,root,755)
224 # suid needed? NO!
225 %attr(755,root,root) %{_bindir}/fusermount
226 # do it ! failed
227 # %%attr(755,root,root) %{_sbindir}/mount.fuse
228 %endif
229
230 %files -n libfuse
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
233
234 %files -n libfuse-devel
235 %defattr(644,root,root,755)
236 %{_includedir}/fuse.h
237 %{_libdir}/libfuse.la
238 %attr(755,root,root) %{_libdir}/libfuse.so
239
240 %files -n libfuse-static
241 %defattr(644,root,root,755)
242 %{_libdir}/libfuse.a
This page took 0.045817 seconds and 4 git commands to generate.