]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- 1.1, not tested
[packages/libfuse.git] / libfuse.spec
1 %define kernelversion   %(uname -r)
2 %define fusemoduledir   /lib/modules/%{kernelversion}/kernel/fs/fuse
3
4 %bcond_without dist_kernel      # without distribution kernel
5 %bcond_without smp              # without smp packages
6
7 %define kernelrel       %(uname -r | sed -e s/-/_/g)
8 #%%define               _rel    0.1
9 #%%define               _pre    pre2
10
11 #fuse is required by siefs package
12
13 # there is another packet in repo named fuse - zx spectrum emulator -- help
14 Name:           fuse
15 Version:        1.1
16 Release:        1.1@%{_kernel_ver_str}
17 Summary:        Filesystem in Userspace
18 Summary(pl):    System plików w przestrzeni u¿ytkownika
19 Source0:        http://dl.sourceforge.net/avf/%{name}-%{version}.tar.gz
20 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
21 License:        GPL
22 Group:          Applications/System
23 URL:            http://sourceforge.net/projects/avf
24 %{?with_dist_kernel:BuildRequires:      kernel-headers >= 2.4.0 }
25 %{?with_dist_kernel:BuildRequires:      kernel-source >= 2.4.0 }
26 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27 # some parts of this specfile are taken from Ian Pilcher's specfile
28
29 %description
30 FUSE (Filesystem in Userspace) is a simple interface for userspace
31 programs to export a virtual filesystem to the Linux kernel. FUSE also
32 aims to provide a secure method for non privileged users to create and
33 mount their own filesystem implementations.
34
35 %description -l pl
36 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
37 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
38 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
39 montowania w³asnych implementacji systemów plików przez zwyk³ych
40 (nieuprzywilejowanych) u¿ytkowników.
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %prep
46 %setup -q
47
48 %build
49 # invoke configure with the --with-kernel option in case we attempt to
50 # compile for a different kernel and hope the path is right :-)
51
52 #if [ "%{kernelversion}" != $(uname -r) ]; then
53 #       for dir in /lib/modules/%{kernelversion}/build \
54 #%{_kernelsrcdir}-%{kernelversion} \
55 #%{_prefix}/local/src/linux-%{kernelversion} ; do
56 #               if [ -d "$dir" ]; then
57 #                       WITH_KERNEL="--with-kernel=$dir"
58 #                       break
59 #               fi
60 #       done
61 #fi
62
63 ./configure \
64         --prefix=%{_prefix} \
65         $WITH_KERNEL
66 %{__make}
67 %{__make} check
68
69 ## Now build the library as a shared object
70 #cd lib
71 #gcc -fPIC -DHAVE_CONFIG_H -I../include -Wall -W -g -O2 -c *.c
72 #gcc -shared -Wl,-soname,libfuse.so.%{major_ver} -o libfuse.so.%{version} *.o
73 #cd ..
74
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         prefix=$RPM_BUILD_ROOT%{_prefix} \
81         fusemoduledir=$RPM_BUILD_ROOT%{fusemoduledir}
82
83 install -d $RPM_BUILD_ROOT%{_prefix}/lib/fuse/example
84 install -s -m 755 example/{fusexmp,hello,null} $RPM_BUILD_ROOT%{_prefix}/lib/fuse/example/
85
86 # remove binaries form example folder so we can include it
87 # as a form of documentation into the package
88 %{__make} -C example clean
89 rm -rf example/.deps/
90
91 %post
92 /sbin/depmod -aq
93
94 %preun
95 /sbin/modprobe -r fuse
96
97 %postun
98 /sbin/depmod -aq
99
100
101
102 %files
103 %defattr(644,root,root,755)
104 %doc README TODO NEWS INSTALL ChangeLog AUTHORS COPYING COPYING.LIB
105 %doc example/
106 %doc patch/
107
108 %{fusemoduledir}
109 %{_prefix}/lib/libfuse.a
110 %{_includedir}/fuse.h
111 %{_prefix}/lib/fuse/
112
113 # you want to install fusermount SUID root?
114 # Then uncomment the "%attr()"-line in favour of the line after it.
115 #%attr(4500,root,root) %{prefix}/bin/fusermount
116 %attr(755,root,root) %{_bindir}/fusermount
This page took 0.039541 seconds and 4 git commands to generate.