]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- undefined symbol vfs_permission fixed.
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 Name:           kernel-misc-fuse
10 Summary:        Filesystem in Userspace
11 Summary(pl):    System plików w przestrzeni u¿ytkownika
12 Version:        1.4
13 %define         _rel    0.2
14 Release:        %{_rel}@%{_kernel_ver_str}
15 License:        GPL v2
16 Group:          Base/Kernel
17 Source0:        http://dl.sourceforge.net/sourceforge/fuse/fuse-%{version}.tar.gz
18 # Source0-md5:  abdcb47a202d84d844ffbb58dcc7ac8b
19 # Source0-size: 126361
20 Patch0:         %{name}-configure.in.patch
21 Patch1:         %{name}-perm.patch
22 URL:            http://fuse.sourceforge.net/
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 %if %{with kernel}
26 %{?with_dist_kernel:BuildRequires:      kernel-module-build >= 2.6.7}
27 BuildRequires:  rpmbuild(macros) >= 1.153
28 %endif
29 %{?with_dist_kernel:%requires_releq_kernel_up}
30 Requires(post,postun):  /sbin/depmod
31 %{?with_dist_kernel:Requires(postun):   kernel}
32 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 FUSE (Filesystem in Userspace) is a simple interface for userspace
36 programs to export a virtual filesystem to the Linux kernel. FUSE also
37 aims to provide a secure method for non privileged users to create and
38 mount their own filesystem implementations.
39
40 %description -l pl
41 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
42 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
43 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
44 montowania w³asnych implementacji systemów plików przez zwyk³ych
45 (nieuprzywilejowanych) u¿ytkowników.
46
47 %package -n kernel-smp-misc-fuse
48 Summary:        Filesystem in Userspace
49 Summary(pl):    System plików w przestrzeni u¿ytkownika
50 Release:        %{_rel}@%{_kernel_ver_str}
51 License:        GPL v2
52 Group:          Base/Kernel
53 Provides:       kernel-misc-fuse
54 %{?with_dist_kernel:%requires_releq_kernel_smp}
55 Requires(post,postun):  /sbin/depmod
56 %{?with_dist_kernel:Requires(postun):   kernel-smp}
57
58 %description -n kernel-smp-misc-fuse
59 FUSE (Filesystem in Userspace) is a simple interface for userspace
60 programs to export a virtual filesystem to the Linux kernel. FUSE also
61 aims to provide a secure method for non privileged users to create and
62 mount their own filesystem implementations.
63
64 %description -n kernel-smp-misc-fuse -l pl
65 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
66 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
67 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
68 montowania w³asnych implementacji systemów plików przez zwyk³ych
69 (nieuprzywilejowanych) u¿ytkowników.
70
71 %package -n libfuse
72 Summary:        Shared library for Filesytem in Userspace
73 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
74 Group:          Applications/System
75 Release:        %{_rel}
76
77 %description -n libfuse
78 Shared library for Filesytem in Userspace
79
80 %description -n libfuse -l pl
81 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
82
83 %package -n libfuse-devel
84 Summary:        Filesytem in Userspace - Development header fiels and libraries
85 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
86 Group:          Development/Libraries
87 Release:        %{_rel}
88 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
89
90 %description -n libfuse-devel
91 Libfuse library header files.
92
93 %description -n libfuse-devel -l pl
94 Libfuse biblioteki nag³ówkowe dla programistów.
95
96 %package -n libfuse-static
97 Summary:        Filesytem in Userspace - static libraries
98 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
99 Group:          Development/Libraries
100 Release:        %{_rel}
101 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
102
103 %description -n libfuse-static
104 Static libfuse libraries.
105
106 %description -n libfuse-static -l pl
107 Statyczne biblioteki libfuse
108
109 %package -n fusermount
110 Summary:        Filesytem in Userspace utilities
111 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
112 Group:          Applications/System
113 Release:        %{_rel}
114
115 %description -n fusermount
116 Filesytem in Userspace utilities. It provide a secure method for non
117 privileged users to create and mount their own filesystem implementations. 
118
119 %description -n fusermount -l pl
120 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
121 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %prep
127 %setup -q -n fuse-%{version}
128 %patch0 -p1
129 %patch1 -p1
130
131 %build
132 %{__aclocal}
133 %{__autoconf}
134 %{__automake}
135 %configure \
136     --enable-lib \
137     --enable-util \
138     --with-kernel=%{_kernelsrcdir}
139
140 %if %{with kernel}
141 cd kernel
142 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
143     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
144         exit 1
145     fi
146     rm -rf include
147     install -d include/{linux,config}
148     ln -sf %{_kernelsrcdir}/config-$cfg .config
149     ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
150     ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
151     touch include/config/MARKER
152     %{__make} -C %{_kernelsrcdir} clean \
153         EXTRA_CFLAGS="-I../include -DFUSE_VERSION='1.4'" \
154         RCS_FIND_IGNORE="-name '*.ko' -o" \
155         M=$PWD O=$PWD \
156         %{?with_verbose:V=1}
157     %{__make} -C %{_kernelsrcdir} modules \
158         EXTRA_CFLAGS="-I../include -DFUSE_VERSION='1.4'" \
159         RCS_FIND_IGNORE="-name '*.ko' -o" \
160         CC="%{__cc}" CPP="%{__cpp}" \
161         M=$PWD O=$PWD \
162         %{?with_verbose:V=1}
163
164     mv fuse.ko fuse-$cfg.ko
165 done
166 cd -
167 %endif
168
169 cd lib
170 for f in fuse.c fuse_mt.c helper.c mount.c; do
171 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
172 done
173 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
174 cd -
175
176 %{?with_userspace:%{__make} -C util}
177
178 %install
179 rm -rf $RPM_BUILD_ROOT
180
181 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
182
183 %if %{with userspace}
184 cd util
185 install fusermount $RPM_BUILD_ROOT%{_bindir}/
186 cd -
187 %endif
188
189 %if %{with kernel}
190 cd kernel
191 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
192 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
193         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
194 %if %{with smp} && %{with dist_kernel}
195 install fuse-smp.ko \
196         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
197 %endif
198 cd -
199 %endif
200
201 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}
202 cd lib
203 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
204 cd -
205
206 %post
207 %depmod %{_kernel_ver}
208
209 %postun
210 %depmod %{_kernel_ver}
211
212 %post -n kernel-smp-misc-fuse
213 %depmod %{_kernel_ver}
214
215 %postun -n kernel-smp-misc-fuse
216 %depmod %{_kernel_ver}
217
218 %if %{with kernel}
219 %files
220 %defattr(644,root,root,755)
221 %doc README NEWS ChangeLog AUTHORS
222 %doc patch/
223 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
224
225 %if %{with smp} && %{with dist_kernel}
226 %files -n kernel-smp-misc-fuse
227 %defattr(644,root,root,755)
228 %doc README NEWS ChangeLog AUTHORS
229 %doc patch/
230 /lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko*
231 %endif
232 %endif
233
234 %if %{with userspace}
235 %files -n fusermount
236 %defattr(644,root,root,755)
237 # suid needed? NO!
238 %attr(755,root,root) %{_bindir}/fusermount
239 # do it ! failed
240 # %%attr(755,root,root) %{_sbindir}/mount.fuse
241 %endif
242
243 %files -n libfuse
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
246
247 %files -n libfuse-devel
248 %defattr(644,root,root,755)
249 %{_includedir}/fuse.h
250 %{_libdir}/libfuse.la
251 %attr(755,root,root) %{_libdir}/libfuse.so
252
253 %files -n libfuse-static
254 %defattr(644,root,root,755)
255 %{_libdir}/libfuse.a
This page took 0.047544 seconds and 4 git commands to generate.