]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- updated to 0.18.2
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.18.2
11 Release:        1
12 License:        GPL v2+
13 Group:          Libraries
14 Source0:        https://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  b72d406002aff5128651ab8d7a6666c4
16 URL:            https://lib.filezilla-project.org/
17 %{?with_tests:BuildRequires:    cppunit-devel >= 1.13.0}
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %if %{with tests} && %(locale -a | grep -q '^C\.utf8$'; echo $?)
20 BuildRequires:  glibc-localedb-all
21 %endif
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake
24 BuildRequires:  gettext-tools >= 0.11.0
25 BuildRequires:  gnutls-devel >= 3.5.7
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  nettle-devel >= 3.1
28 BuildRequires:  pkgconfig >= 1:0.7
29 # -std=c++17
30 BuildRequires:  libstdc++-devel >= 6:7
31 BuildRequires:  rpmbuild(macros) >= 1.583
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libfilezilla is a free, open source C++ library, offering some basic
36 functionality to build high-performing, platform-independent programs.
37 Some of the highlights include:
38
39 - A typesafe, multi-threaded event system that's very simple to use
40   yet extremely efficient
41 - Timers for periodic events
42 - A datetime class that not only tracks timestamp but also their
43   accuracy, which simplifies dealing with timestamps originating from
44   different sources
45 - Simple process handling for spawning child processes with redirected
46   I/O
47
48 %description -l pl.UTF-8
49 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
50 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
51 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
52 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
53   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
54 - zegary do zdarzeń regularnych
55 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
56   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
57   różnych źródeł
58 - prostą obsługę procesów do tworzenia procesów potomnych z
59   przekierowanym wejściem/wyjściem
60
61 %package devel
62 Summary:        Header files for libfilezilla library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       libstdc++-devel >= 6:7
67 Requires:       gnutls-devel >= 3.5.7
68 Requires:       nettle-devel >= 3.1
69
70 %description devel
71 Header files for libfilezilla library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe biblioteki libfilezilla.
75
76 %package static
77 Summary:        Static libfilezilla library
78 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 Static libfilezilla library.
84
85 %description static -l pl.UTF-8
86 Statyczna biblioteka libfilezilla.
87
88 %package apidocs
89 Summary:        %{name} API documentation
90 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
91 Group:          Documentation
92
93 %description apidocs
94 API documentation for %{name} library.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API biblioteki %{name}.
98
99 %prep
100 %setup -q
101
102 cd locales
103 %{__mv} bg{_BG,}.po
104 %{__mv} ca{_ES,}@valencia.po
105 %{__mv} cs{_CZ,}.po
106 %{__mv} fa{_IR,}.po
107 %{__mv} fi{_FI,}.po
108 %{__mv} gl{_ES,}.po
109 %{__mv} he{_IL,}.po
110 %{__mv} hu{_HU,}.po
111 %{__mv} id{_ID,}.po
112 %{__mv} ja{_JP,}.po
113 %{__mv} ko{_KR,}.po
114 %{__mv} lo{_LA,}.po
115 %{__mv} lt{_LT,}.po
116 %{__mv} lv{_LV,}.po
117 %{__mv} mk{_MK,}.po
118 %{__mv} nb{_NO,}.po
119 %{__mv} nn{_NO,}.po
120 %{__mv} pl{_PL,}.po
121 %{__mv} pt{_PT,}.po
122 %{__mv} ro{_RO,}.po
123 %{__mv} sk{_SK,}.po
124 %{__mv} sl{_SI,}.po
125 %{__mv} th{_TH,}.po
126 %{__mv} uk{_UA,}.po
127 %{__mv} vi{_VN,}.po
128
129 %build
130 %{__libtoolize}
131 %{__aclocal} -I m4
132 %{__autoconf}
133 %{__autoheader}
134 %{__automake}
135 %configure \
136         %{!?with_static_libs:--disable-static}
137 %{__make}
138
139 %if %{with tests}
140 # wide char conversion test fails with plain C locale
141 LC_ALL=C.UTF-8 \
142 %{__make} check
143 %endif
144
145 %if %{with apidocs}
146 %{__make} -C doc html
147 %endif
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
156
157 # not supported by glibc (as of 2.25)
158 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/co
159
160 %find_lang %{name}
161
162 %clean
163 rm -rf $RPM_BUILD_ROOT
164
165 %post   -p /sbin/ldconfig
166 %postun -p /sbin/ldconfig
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README
171 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
172 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
173
174 %files devel
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_libdir}/libfilezilla.so
177 %{_includedir}/libfilezilla
178 %{_pkgconfigdir}/libfilezilla.pc
179
180 %if %{with static_libs}
181 %files static
182 %defattr(644,root,root,755)
183 %{_libdir}/libfilezilla.a
184 %endif
185
186 %if %{with apidocs}
187 %files apidocs
188 %defattr(644,root,root,755)
189 %doc doc/doxygen-doc/html/*
190 %endif
This page took 0.072252 seconds and 4 git commands to generate.