]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- updated to 0.9.1
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.9.1
11 Release:        1
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  4676304b048869ab6ac6ae09a1ab29f9
16 URL:            http://lib.filezilla-project.org/
17 %{?with_tests:BuildRequires:    cppunit-devel >= 1.10.2}
18 %{?with_apidocs:BuildRequires:  doxygen}
19 %if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
20 BuildRequires:  glibc-localedb-all
21 %endif
22 # -std=c++14
23 BuildRequires:  libstdc++-devel >= 6:5
24 BuildRequires:  rpmbuild(macros) >= 1.583
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 libfilezilla is a free, open source C++ library, offering some basic
29 functionality to build high-performing, platform-independent programs.
30 Some of the highlights include:
31
32 - A typesafe, multi-threaded event system that's very simple to use
33   yet extremely efficient
34 - Timers for periodic events
35 - A datetime class that not only tracks timestamp but also their
36   accuracy, which simplifies dealing with timestamps originating from
37   different sources
38 - Simple process handling for spawning child processes with redirected
39   I/O
40
41 %description -l pl.UTF-8
42 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
43 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
44 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
45 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
46   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
47 - zegary do zdarzeń regularnych
48 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
49   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
50   różnych źródeł
51 - prostą obsługę procesów do tworzenia procesów potomnych z
52   przekierowanym wejściem/wyjściem
53
54 %package devel
55 Summary:        Header files for libfilezilla library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       libstdc++-devel >= 6:5
60
61 %description devel
62 Header files for libfilezilla library.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe biblioteki libfilezilla.
66
67 %package static
68 Summary:        Static libfilezilla library
69 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static libfilezilla library.
75
76 %description static -l pl.UTF-8
77 Statyczna biblioteka libfilezilla.
78
79 %package apidocs
80 Summary:        %{name} API documentation
81 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
82 Group:          Documentation
83
84 %description apidocs
85 API documentation for %{name} library.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API biblioteki %{name}.
89
90 %prep
91 %setup -q
92
93 %build
94 %configure \
95         %{!?with_static_libs:--disable-static}
96 %{__make}
97
98 %if %{with tests}
99 # wide char conversion test fails with plain C locale
100 LC_ALL=C.UTF-8 \
101 %{__make} check
102 %endif
103
104 %if %{with apidocs}
105 %{__make} -C doc html
106 %endif
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110
111 %{__make} install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post   -p /sbin/ldconfig
120 %postun -p /sbin/ldconfig
121
122 %files
123 %defattr(644,root,root,755)
124 %doc AUTHORS ChangeLog NEWS README
125 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
126 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
127
128 %files devel
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/libfilezilla.so
131 %{_includedir}/libfilezilla
132 %{_pkgconfigdir}/libfilezilla.pc
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/libfilezilla.a
138 %endif
139
140 %if %{with apidocs}
141 %files apidocs
142 %defattr(644,root,root,755)
143 %doc doc/doxygen-doc/html/*
144 %endif
This page took 0.262534 seconds and 4 git commands to generate.