]> git.pld-linux.org Git - packages/libfilezilla.git/blob - libfilezilla.spec
- updated to 0.9.2
[packages/libfilezilla.git] / libfilezilla.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # doxygen API documentation
4 %bcond_without  static_libs     # static library
5 %bcond_without  tests           # "make check"
6 #
7 Summary:        Library for high-performing platform-independent programs
8 Summary(pl.UTF-8):      Biblioteka do wydajnych programów niezależnych od platformy
9 Name:           libfilezilla
10 Version:        0.9.2
11 Release:        1
12 License:        GPL v2
13 Group:          Libraries
14 Source0:        http://download.filezilla-project.org/libfilezilla/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d52a0e7229efb3c9fafc8a2b649d665d
16 Patch0:         cppunit-pkgconfig.patch
17 URL:            http://lib.filezilla-project.org/
18 %{?with_tests:BuildRequires:    cppunit-devel >= 1.10.2}
19 %{?with_apidocs:BuildRequires:  doxygen}
20 %if %{with tests} && %(locale -a | grep -q '^C\.UTF-8$'; echo $?)
21 BuildRequires:  glibc-localedb-all
22 %endif
23 BuildRequires:  autoconf >= 2.50
24 BuildRequires:  automake
25 BuildRequires:  libtool >= 2:2
26 BuildRequires:  pkgconfig >= 1:0.7
27 # -std=c++14
28 BuildRequires:  libstdc++-devel >= 6:5
29 BuildRequires:  rpmbuild(macros) >= 1.583
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libfilezilla is a free, open source C++ library, offering some basic
34 functionality to build high-performing, platform-independent programs.
35 Some of the highlights include:
36
37 - A typesafe, multi-threaded event system that's very simple to use
38   yet extremely efficient
39 - Timers for periodic events
40 - A datetime class that not only tracks timestamp but also their
41   accuracy, which simplifies dealing with timestamps originating from
42   different sources
43 - Simple process handling for spawning child processes with redirected
44   I/O
45
46 %description -l pl.UTF-8
47 libfilezilla to wolnodostępna biblioteka C++ o otwartych źródłach,
48 oferująca pewną podstawową funkcjonalność do tworzenia wydajnych
49 programów niezależnych od platformy. Uwzględnione funkcje obejmują:
50 - bezpieczny pod względem typów, wielowątkowy system zdarzeń -
51   bardzo prosty w użyciu, a jednocześnie bardzo wydajny
52 - zegary do zdarzeń regularnych
53 - klasa daty i czasu nie tylko śledząca znacznik czasu, ale także jego
54   dokładność, co upraszcza obsługę znaczników czasu pochodzących z
55   różnych źródeł
56 - prostą obsługę procesów do tworzenia procesów potomnych z
57   przekierowanym wejściem/wyjściem
58
59 %package devel
60 Summary:        Header files for libfilezilla library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libfilezilla
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       libstdc++-devel >= 6:5
65
66 %description devel
67 Header files for libfilezilla library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki libfilezilla.
71
72 %package static
73 Summary:        Static libfilezilla library
74 Summary(pl.UTF-8):      Statyczna biblioteka libfilezilla
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static libfilezilla library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka libfilezilla.
83
84 %package apidocs
85 Summary:        %{name} API documentation
86 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
87 Group:          Documentation
88
89 %description apidocs
90 API documentation for %{name} library.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki %{name}.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 %{__libtoolize}
101 %{__aclocal} -I m4
102 %{__autoconf}
103 %{__autoheader}
104 %{__automake}
105 %configure \
106         %{!?with_static_libs:--disable-static}
107 %{__make}
108
109 %if %{with tests}
110 # wide char conversion test fails with plain C locale
111 LC_ALL=C.UTF-8 \
112 %{__make} check
113 %endif
114
115 %if %{with apidocs}
116 %{__make} -C doc html
117 %endif
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
126
127 %clean
128 rm -rf $RPM_BUILD_ROOT
129
130 %post   -p /sbin/ldconfig
131 %postun -p /sbin/ldconfig
132
133 %files
134 %defattr(644,root,root,755)
135 %doc AUTHORS ChangeLog NEWS README
136 %attr(755,root,root) %{_libdir}/libfilezilla.so.*.*.*
137 %attr(755,root,root) %ghost %{_libdir}/libfilezilla.so.0
138
139 %files devel
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_libdir}/libfilezilla.so
142 %{_includedir}/libfilezilla
143 %{_pkgconfigdir}/libfilezilla.pc
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/libfilezilla.a
149 %endif
150
151 %if %{with apidocs}
152 %files apidocs
153 %defattr(644,root,root,755)
154 %doc doc/doxygen-doc/html/*
155 %endif
This page took 0.076246 seconds and 4 git commands to generate.