]> git.pld-linux.org Git - packages/libffi.git/blob - libffi.spec
41ce7877633005415826ca832dacc7cda98fc9db
[packages/libffi.git] / libffi.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Foreign Function Interface library
6 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface
7 Name:           libffi
8 Version:        3.0.8
9 Release:        1
10 Epoch:          7
11 License:        MIT-like
12 Group:          Libraries
13 Source0:        ftp://sourceware.org/pub/libffi/%{name}-%{version}.tar.gz
14 # Source0-md5:  188a4f79fdac2310044b44b7d3918ef9
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-m4.patch
17 URL:            http://sources.redhat.com/libffi/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The libffi library provides a portable, high level programming
25 interface to various calling conventions. This allows a programmer to
26 call any function specified by a call interface description at
27 run-time.
28
29 Ffi stands for Foreign Function Interface. A foreign function
30 interface is the popular name for the interface that allows code
31 written in one language to call code written in another language. The
32 libffi library really only provides the lowest, machine dependent
33 layer of a fully featured foreign function interface. A layer must
34 exist above libffi that handles type conversions for values passed
35 between the two languages.
36
37 %description -l pl.UTF-8
38 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
39 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
40 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
41 działania programu.
42
43 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
44 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
45 napisanemu w jednym języku wywoływać kod napisany w innym języku.
46 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
47 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
48 typów dla wartości przekazywanych pomiędzy różnymi językami.
49
50 %package devel
51 Summary:        libffi development package
52 Summary(pl.UTF-8):      libffi - część dla programistów
53 Group:          Development/Libraries
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55
56 %description devel
57 Header files for libffi.
58
59 %description devel -l pl.UTF-8
60 Pliki nagłówkowe do biblioteki libffi.
61
62 %package static
63 Summary:        libffi static library
64 Summary(pl.UTF-8):      Statyczna biblioteka libffi
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
67
68 %description static
69 Static version of libffi.
70
71 %description static -l pl.UTF-8
72 Statyczna wersja biblioteki libffi.
73
74 %prep
75 %setup -q
76 %patch0 -p1
77 %patch1 -p1
78
79 %build
80 %{__libtoolize}
81 %{__aclocal}
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         %{!?with_static_libs:--disable-static}
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 rm $RPM_BUILD_ROOT%{_infodir}/dir
97
98 %clean
99 rm -rf $RPM_BUILD_ROOT
100
101 %post   -p /sbin/ldconfig
102 %postun -p /sbin/ldconfig
103
104 %post   devel -p /sbin/postshell
105 -/usr/sbin/fix-info-dir -c %{_infodir}
106
107 %postun devel -p /sbin/postshell
108 -/usr/sbin/fix-info-dir -c %{_infodir}
109
110 %files
111 %defattr(644,root,root,755)
112 %doc ChangeLog* LICENSE README
113 %attr(755,root,root) %{_libdir}/libffi.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libffi.so.5
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libffi.so
119 %{_libdir}/libffi.la
120 %{_libdir}/libffi-%{version}
121 %{_pkgconfigdir}/libffi.pc
122 %{_mandir}/man3/ffi*.3*
123 %{_infodir}/libffi.info*
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libffi.a
129 %endif
This page took 0.111467 seconds and 2 git commands to generate.