]> git.pld-linux.org Git - packages/libexif.git/blob - libexif.spec
- fix libexif includes
[packages/libexif.git] / libexif.spec
1 #
2 # NOTE:
3 # - exif headers should be included as <libexif/something.h>
4 #   so don't ,,fix'' pkgconfig file
5
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8 #
9 Summary:        Library for parsing EXIF files from digital cameras
10 Summary(pl):    Biblioteka do czytania plików EXIF z kamer cyfrowych
11 Name:           libexif
12 Version:        0.6.13
13 Release:        3
14 Epoch:          1
15 License:        MIT
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libexif/%{name}-%{version}.tar.bz2
18 # Source0-md5:  1b1e2b495c5aa20c08725f30545a110b
19 Patch0:         %{name}-pl.po-update.patch
20 URL:            http://libexif.sourceforge.net/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.8
23 BuildRequires:  doxygen
24 BuildRequires:  gettext-devel >= 0.14.1
25 BuildRequires:  libtool
26 Obsoletes:      libexif7
27 Obsoletes:      libmnote
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Most digital cameras produce EXIF files, which are JPEG files with
32 extra tags that contain information about the image. The EXIF library
33 allows you to parse an EXIF file and read the data from those tags.
34
35 %description -l pl
36 Wiêkszo¶æ kamer cyfrowych tworzy pliki EXIF, które s± JPEGami z
37 dodatkowymi znacznikami zawieraj±cymi informacje o obrazie. Biblioteka
38 EXIF pozwala czytaæ informacje z tych znaczników.
39
40 %package devel
41 Summary:        Header files for libexif
42 Summary(pl):    Pliki nag³ówkowe dla libexif
43 Group:          Development/Libraries
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45 Obsoletes:      libexif7-devel
46 Obsoletes:      libmnote-devel
47
48 %description devel
49 Header files for libexif.
50
51 %description devel -l pl
52 Pliki nag³ówkowe dla libexif.
53
54 %package static
55 Summary:        Static version of libexif
56 Summary(pl):    Statyczna wersja libexif
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
59 Obsoletes:      libmnote-static
60
61 %description static
62 Static version of libexif.
63
64 %description static -l pl
65 Statyczna wersja libexif.
66
67 %package apidocs
68 Summary:        libexif API documentation
69 Summary(pl):    Dokumentacja API biblioteki libexif
70 Group:          Documentation
71
72 %description apidocs
73 API and internal documentation for libexif library.
74
75 %description apidocs -l pl
76 Dokumentacja API oraz wewnêtrzna dla biblioteki libexif.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 rm -f po/stamp-po
83
84 %build
85 %{__gettextize}
86 %{__libtoolize}
87 %{__aclocal} -I m4m
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         %{!?with_static_libs:--disable-static}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 rm -rf $RPM_BUILD_ROOT%{_docdir}/libexif
103
104 %find_lang %{name}-12
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files -f %{name}-12.lang
113 %defattr(644,root,root,755)
114 %doc README ChangeLog
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_includedir}/%{name}
122 %{_pkgconfigdir}/*.pc
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/lib*.a
128 %endif
129
130 %files apidocs
131 %defattr(644,root,root,755)
132 %doc doc/doxygen-output/libexif*
This page took 0.049792 seconds and 3 git commands to generate.