]> git.pld-linux.org Git - packages/libexif.git/blob - libexif.spec
- License is LGPL (v2+)
[packages/libexif.git] / libexif.spec
1 #
2 # NOTE:
3 # - exif headers should be included as <libexif/something.h>
4 #   so don't ,,fix'' pkgconfig file
5 #
6 # Conditional build:
7 %bcond_without  static_libs     # don't build static library
8 #
9 Summary:        Library for parsing EXIF files from digital cameras
10 Summary(pl.UTF-8):      Biblioteka do czytania plików EXIF z kamer cyfrowych
11 Name:           libexif
12 Version:        0.6.17
13 Release:        1
14 Epoch:          1
15 License:        LGPL v2+
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libexif/%{name}-%{version}.tar.bz2
18 # Source0-md5:  f7cf4e623a48c9a3b13f7f95f0a41015
19 Patch0:         %{name}-pl.po-update.patch
20 URL:            http://libexif.sourceforge.net/
21 BuildRequires:  autoconf >= 2.59
22 BuildRequires:  automake >= 1:1.9
23 BuildRequires:  doxygen
24 BuildRequires:  gettext-devel >= 0.14.1
25 BuildRequires:  libtool
26 Obsoletes:      libexif7
27 Obsoletes:      libmnote
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Most digital cameras produce EXIF files, which are JPEG files with
32 extra tags that contain information about the image. The EXIF library
33 allows you to parse an EXIF file and read the data from those tags.
34
35 %description -l pl.UTF-8
36 Większość kamer cyfrowych tworzy pliki EXIF, które są JPEGami z
37 dodatkowymi znacznikami zawierającymi informacje o obrazie. Biblioteka
38 EXIF pozwala czytać informacje z tych znaczników.
39
40 %package devel
41 Summary:        Header files for libexif
42 Summary(pl.UTF-8):      Pliki nagłówkowe dla libexif
43 Group:          Development/Libraries
44 Requires:       %{name} = %{epoch}:%{version}-%{release}
45 Obsoletes:      libexif7-devel
46 Obsoletes:      libmnote-devel
47
48 %description devel
49 Header files for libexif.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe dla libexif.
53
54 %package static
55 Summary:        Static version of libexif
56 Summary(pl.UTF-8):      Statyczna wersja libexif
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
59 Obsoletes:      libmnote-static
60
61 %description static
62 Static version of libexif.
63
64 %description static -l pl.UTF-8
65 Statyczna wersja libexif.
66
67 %package apidocs
68 Summary:        libexif API documentation
69 Summary(pl.UTF-8):      Dokumentacja API biblioteki libexif
70 Group:          Documentation
71
72 %description apidocs
73 API and internal documentation for libexif library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API oraz wewnętrzna dla biblioteki libexif.
77
78 %prep
79 %setup -q
80 %patch0 -p1
81
82 rm -f po/stamp-po
83
84 %build
85 %{__gettextize}
86 %{__libtoolize}
87 %{__aclocal} -I m4m
88 %{__autoconf}
89 %{__autoheader}
90 %{__automake}
91 %configure \
92         %{!?with_static_libs:--disable-static}
93
94 # docs generation fails with -jN>1
95 %{__make} -j1
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 rm -rf $RPM_BUILD_ROOT%{_docdir}/libexif
104
105 %find_lang %{name}-12
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post   -p /sbin/ldconfig
111 %postun -p /sbin/ldconfig
112
113 %files -f %{name}-12.lang
114 %defattr(644,root,root,755)
115 %doc AUTHORS ChangeLog NEWS README
116 %attr(755,root,root) %{_libdir}/libexif.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libexif.so.12
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libexif.so
122 %{_libdir}/libexif.la
123 %{_includedir}/%{name}
124 %{_pkgconfigdir}/libexif.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libexif.a
130 %endif
131
132 %files apidocs
133 %defattr(644,root,root,755)
134 %doc doc/doxygen-output/libexif*
This page took 0.103839 seconds and 3 git commands to generate.