]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
- restore rev 1.38
[packages/libevent.git] / libevent.spec
1 # TODO
2 # - %attr(755,root,root) %{_bindir}/event_rpcgen.py
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static library
6 #
7 Summary:        libevent - an event notification library
8 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
9 Name:           libevent
10 Version:        2.0.10
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://www.monkey.org/~provos/%{name}-%{version}-stable.tar.gz
15 # Source0-md5:  a37401d26cbbf28185211d582741a3d4
16 Patch0:         %{name}-fpm.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.monkey.org/~provos/libevent/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 Obsoletes:      libevent-dietlibc
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The libevent API provides a mechanism to execute a callback function
28 when a specific event occurs on a file descriptor or after a timeout
29 has been reached. It is meant to replace the asynchronous event loop
30 found in event-driven network servers.
31
32 %description -l pl.UTF-8
33 API libevent dostarcza mechanizm do wykonywania funkcji callback,
34 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
35 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
36 sterowanych zdarzeniami usługach sieciowych.
37
38 %package devel
39 Summary:        Header files for libevent library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for libevent library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki libevent.
49
50 %package static
51 Summary:        Static libevent library
52 Summary(pl.UTF-8):      Statyczna biblioteka libevent
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libevent library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka libevent.
61
62 %prep
63 %setup -q -n %{name}-%{version}-stable
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 %{__libtoolize}
69 %{__aclocal} -I m4
70 %{__autoconf}
71 %{__automake}
72 %configure \
73         %{!?with_static_libs:--disable-static}
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post   -p /sbin/ldconfig
86 %postun -p /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libevent-2.0.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libevent-2.0.so.5
92 %attr(755,root,root) %{_libdir}/libevent_core-2.0.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libevent_core-2.0.so.5
94 %attr(755,root,root) %{_libdir}/libevent_extra-2.0.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-2.0.so.5
96 %attr(755,root,root) %{_libdir}/libevent_openssl-2.0.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libevent_openssl-2.0.so.5
98 %attr(755,root,root) %{_libdir}/libevent_pthreads-2.0.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libevent_pthreads-2.0.so.5
100
101 %files devel
102 %defattr(644,root,root,755)
103 # R: python
104 %attr(755,root,root) %{_bindir}/event_rpcgen.py
105 %attr(755,root,root) %{_libdir}/libevent.so
106 %attr(755,root,root) %{_libdir}/libevent_core.so
107 %attr(755,root,root) %{_libdir}/libevent_extra.so
108 %attr(755,root,root) %{_libdir}/libevent_openssl.so
109 %attr(755,root,root) %{_libdir}/libevent_pthreads.so
110 %{_libdir}/libevent.la
111 %{_libdir}/libevent_core.la
112 %{_libdir}/libevent_extra.la
113 %{_libdir}/libevent_openssl.la
114 %{_libdir}/libevent_pthreads.la
115 %dir %{_includedir}/event2
116 %{_includedir}/event2/*.h
117 %{_includedir}/evdns.h
118 %{_includedir}/event*.h
119 %{_includedir}/evhttp.h
120 %{_includedir}/evrpc.h
121 %{_includedir}/evutil.h
122 #%%{_mandir}/man3/evdns.3*
123 #%%{_mandir}/man3/event.3*
124 %{_pkgconfigdir}/libevent.pc
125 %{_pkgconfigdir}/libevent_openssl.pc
126 %{_pkgconfigdir}/libevent_pthreads.pc
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libevent.a
132 %{_libdir}/libevent_core.a
133 %{_libdir}/libevent_extra.a
134 %{_libdir}/libevent_openssl.a
135 %{_libdir}/libevent_pthreads.a
136 %endif
This page took 0.048077 seconds and 3 git commands to generate.