]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
19b46edfe42bd1d19bc43cfd141d3d904554befd
[packages/libevent.git] / libevent.spec
1 # TODO
2 # - %attr(755,root,root) %{_bindir}/event_rpcgen.py
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static library
6 #
7 Summary:        libevent - an event notification library
8 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
9 Name:           libevent
10 Version:        1.4.10
11 Release:        1
12 Epoch:          0
13 License:        BSD
14 Group:          Libraries
15 Source0:        http://www.monkey.org/~provos/%{name}-%{version}-stable.tar.gz
16 # Source0-md5:  20611535f26d415bd6ad380a673d9ea2
17 Patch0:         %{name}-fpm.patch
18 URL:            http://www.monkey.org/~provos/libevent/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The libevent API provides a mechanism to execute a callback function
26 when a specific event occurs on a file descriptor or after a timeout
27 has been reached. It is meant to replace the asynchronous event loop
28 found in event-driven network servers.
29
30 %description -l pl.UTF-8
31 API libevent dostarcza mechanizm do wykonywania funkcji callback,
32 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
33 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
34 sterowanych zdarzeniami usługach sieciowych.
35
36 %package devel
37 Summary:        Header files for libevent library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
39 Group:          Development/Libraries
40 Requires:       %{name} = %{epoch}:%{version}-%{release}
41
42 %description devel
43 Header files for libevent library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki libevent.
47
48 %package static
49 Summary:        Static libevent library
50 Summary(pl.UTF-8):      Statyczna biblioteka libevent
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
53
54 %description static
55 Static libevent library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka libevent.
59
60 %prep
61 %setup -q -n %{name}-%{version}-stable
62 %patch0 -p1
63
64 %build
65 %{__libtoolize}
66 %{__aclocal}
67 %{__autoconf}
68 %{__autoheader}
69 %{__automake}
70 %configure \
71         %{!?with_static_libs:--disable-static}
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %attr(755,root,root) %{_libdir}/libevent-1.4.so.*.*.*
89 %attr(755,root,root) %ghost %{_libdir}/libevent-1.4.so.2
90 %attr(755,root,root) %{_libdir}/libevent_core-1.4.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libevent_core-1.4.so.2
92 %attr(755,root,root) %{_libdir}/libevent_extra-1.4.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-1.4.so.2
94
95 %files devel
96 %defattr(644,root,root,755)
97 # R: python
98 #%attr(755,root,root) %{_bindir}/event_rpcgen.py
99 %attr(755,root,root) %{_libdir}/libevent.so
100 %attr(755,root,root) %{_libdir}/libevent_core.so
101 %attr(755,root,root) %{_libdir}/libevent_extra.so
102 %{_libdir}/libevent.la
103 %{_libdir}/libevent_core.la
104 %{_libdir}/libevent_extra.la
105 %{_includedir}/evdns.h
106 %{_includedir}/event*.h
107 %{_includedir}/evhttp.h
108 %{_includedir}/evrpc.h
109 %{_includedir}/evutil.h
110 %{_mandir}/man3/evdns.3*
111 %{_mandir}/man3/event.3*
112
113 %if %{with static_libs}
114 %files static
115 %defattr(644,root,root,755)
116 %{_libdir}/libevent.a
117 %{_libdir}/libevent_core.a
118 %{_libdir}/libevent_extra.a
119 %endif
This page took 0.736625 seconds and 3 git commands to generate.