]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
- added am patch (fixes build with automake 1.13)
[packages/libevent.git] / libevent.spec
1 # TODO: %{_bindir}/event_rpcgen.py - rename to event_rpcgen?
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        libevent - an event notification library
7 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
8 Name:           libevent
9 Version:        2.0.21
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://github.com/downloads/libevent/libevent/%{name}-%{version}-stable.tar.gz
14 # Source0-md5:  b2405cc9ebf264aa47ff615d9de527a2
15 Patch0:         %{name}-fpm.patch
16 Patch1:         %{name}-link.patch
17 Patch2:         %{name}-am.patch
18 URL:            http://libevent.org/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  openssl-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  zlib-devel
25 Obsoletes:      libevent-dietlibc
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The libevent API provides a mechanism to execute a callback function
30 when a specific event occurs on a file descriptor or after a timeout
31 has been reached. It is meant to replace the asynchronous event loop
32 found in event-driven network servers.
33
34 %description -l pl.UTF-8
35 API libevent dostarcza mechanizm do wykonywania funkcji callback,
36 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
37 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
38 sterowanych zdarzeniami usługach sieciowych.
39
40 %package devel
41 Summary:        Header files for libevent library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       openssl-devel
46
47 %description devel
48 Header files for libevent library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki libevent.
52
53 %package static
54 Summary:        Static libevent library
55 Summary(pl.UTF-8):      Statyczna biblioteka libevent
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static libevent library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libevent.
64
65 %prep
66 %setup -q -n %{name}-%{version}-stable
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70
71 %build
72 %{__libtoolize}
73 %{__aclocal} -I m4
74 %{__autoconf}
75 %{__automake}
76 %configure \
77         %{!?with_static_libs:--disable-static}
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT/%{_lib}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 mv -f $RPM_BUILD_ROOT%{_libdir}/libevent-2.0.so.* $RPM_BUILD_ROOT/%{_lib}
88 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libevent-2.0.so.*.*.*) \
89         $RPM_BUILD_ROOT%{_libdir}/libevent.so
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc ChangeLog LICENSE README
100 %attr(755,root,root) /%{_lib}/libevent-2.0.so.*.*.*
101 %attr(755,root,root) %ghost /%{_lib}/libevent-2.0.so.5
102 %attr(755,root,root) %{_libdir}/libevent_core-2.0.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libevent_core-2.0.so.5
104 %attr(755,root,root) %{_libdir}/libevent_extra-2.0.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-2.0.so.5
106 %attr(755,root,root) %{_libdir}/libevent_openssl-2.0.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libevent_openssl-2.0.so.5
108 %attr(755,root,root) %{_libdir}/libevent_pthreads-2.0.so.*.*.*
109 %attr(755,root,root) %ghost %{_libdir}/libevent_pthreads-2.0.so.5
110
111 %files devel
112 %defattr(644,root,root,755)
113 # R: python
114 %attr(755,root,root) %{_bindir}/event_rpcgen.py
115 %attr(755,root,root) %{_libdir}/libevent.so
116 %attr(755,root,root) %{_libdir}/libevent_core.so
117 %attr(755,root,root) %{_libdir}/libevent_extra.so
118 %attr(755,root,root) %{_libdir}/libevent_openssl.so
119 %attr(755,root,root) %{_libdir}/libevent_pthreads.so
120 %{_libdir}/libevent.la
121 %{_libdir}/libevent_core.la
122 %{_libdir}/libevent_extra.la
123 %{_libdir}/libevent_openssl.la
124 %{_libdir}/libevent_pthreads.la
125 %dir %{_includedir}/event2
126 %{_includedir}/event2/*.h
127 %{_includedir}/evdns.h
128 %{_includedir}/event*.h
129 %{_includedir}/evhttp.h
130 %{_includedir}/evrpc.h
131 %{_includedir}/evutil.h
132 #%%{_mandir}/man3/evdns.3*
133 #%%{_mandir}/man3/event.3*
134 %{_pkgconfigdir}/libevent.pc
135 %{_pkgconfigdir}/libevent_openssl.pc
136 %{_pkgconfigdir}/libevent_pthreads.pc
137
138 %if %{with static_libs}
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libevent.a
142 %{_libdir}/libevent_core.a
143 %{_libdir}/libevent_extra.a
144 %{_libdir}/libevent_openssl.a
145 %{_libdir}/libevent_pthreads.a
146 %endif
This page took 0.057177 seconds and 3 git commands to generate.