]> git.pld-linux.org Git - SPECS.git/blob - libebur128.spec
SPECS updated Thu 20 Jun 07:54:00 CEST 2024
[SPECS.git] / libebur128.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        EBU R 128 standard for loudness normalisation
6 Summary(pl.UTF-8):      Standard normalizacji głośności EBU R 128
7 Name:           libebur128
8 Version:        1.2.6
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 #Source0Download: https://github.com/jiixyj/libebur128/releases
13 Source0:        https://github.com/jiixyj/libebur128/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  d38c5f86f5dccb37b5818b853ad49f32
15 URL:            https://github.com/jiixyj/libebur128
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 libebur128 is a library that implements the EBU R 128 standard for
22 loudness normalisation.
23
24 %description -l pl.UTF-8
25 libebur128 to biblioteka implementująca standard normalizacji
26 głośności EBU R 128.
27
28 %package devel
29 Summary:        Header files for ebur128 library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ebur128
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for ebur128 library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki ebur128.
39
40 %package static
41 Summary:        Static ebur128 library
42 Summary(pl.UTF-8):      Statyczna biblioteka ebur128
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static ebur128 library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka ebur128.
51
52 %prep
53 %setup -q
54
55 %build
56 %if %{with static_libs}
57 install -d build-static
58 cd build-static
59 %cmake .. \
60         -DBUILD_SHARED_LIBS=OFF \
61         -DCMAKE_INSTALL_LIBDIR=%{_lib}
62
63 %{__make}
64 cd ..
65 %endif
66
67 install -d build
68 cd build
69 # .pc file expects relative CMAKE_INSTALL_LIBDIR
70 %cmake .. \
71         -DBUILD_STATIC_LIBS=OFF \
72         -DCMAKE_INSTALL_LIBDIR=%{_lib}
73
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %if %{with static_libs}
80 %{__make} -C build-static install \
81         DESTDIR=$RPM_BUILD_ROOT
82 %endif
83
84 %{__make} -C build install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc COPYING README.md doc/license/R128Scan.txt
96 %attr(755,root,root) %{_libdir}/libebur128.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libebur128.so.1
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libebur128.so
102 %{_includedir}/ebur128.h
103 %{_pkgconfigdir}/libebur128.pc
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libebur128.a
109 %endif
This page took 0.098304 seconds and 4 git commands to generate.