]> git.pld-linux.org Git - SPECS.git/blob - libebur128.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libebur128.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        EBU R 128 standard for loudness normalisation
6 Summary(pl.UTF-8):      Standard normalizacji głośności EBU R 128
7 Name:           libebur128
8 Version:        1.2.4
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        https://github.com/jiixyj/libebur128/archive/v%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  d6131f7e3bbf0cd7301fb5d9f8a30cc1
14 #Patch0:        %{name}-what.patch
15 URL:            https://github.com/jiixyj/libebur128
16 BuildRequires:  cmake >= 2.8.12
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 libebur128 is a library that implements the EBU R 128 standard for
22 loudness normalisation.
23
24 %description -l pl.UTF-8
25 libebur128 to biblioteka implementująca standard normalizacji
26 głośności EBU R 128.
27
28 %package devel
29 Summary:        Header files for ebur128 library
30 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ebur128
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for ebur128 library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki ebur128.
39
40 %package static
41 Summary:        Static ebur128 library
42 Summary(pl.UTF-8):      Statyczna biblioteka ebur128
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static ebur128 library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka ebur128.
51
52 %prep
53 %setup -q
54
55 %build
56 install -d build
57 cd build
58 # .pc file expects relative CMAKE_INSTALL_LIBDIR
59 %cmake .. \
60         %{!?with_static_libs:-DBUILD_STATIC_LIBS=OFF} \
61         -DCMAKE_INSTALL_LIBDIR=%{_lib}
62
63 %{__make}
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc COPYING README.md doc/license/R128Scan.txt
80 %attr(755,root,root) %{_libdir}/libebur128.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libebur128.so.1
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libebur128.so
86 %{_includedir}/ebur128.h
87 %{_pkgconfigdir}/libebur128.pc
88
89 %if %{with static_libs}
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/libebur128.a
93 %endif
This page took 0.493448 seconds and 3 git commands to generate.