]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
- updated to 0.1.2
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
6 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
7 Name:           libe-book
8 Version:        0.1.2
9 Release:        1
10 License:        LGPL v2.1+ or MPL v2.0+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
13 # Source0-md5:  19d84f4a97aab32d350d1f47ea3da0b3
14 Patch0:         %{name}-missing.patch
15 URL:            http://libebook.sourceforge.net/
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf
19 BuildRequires:  libCSS-devel >= 0.3.0
20 BuildRequires:  libhubbub-devel >= 0.3.0
21 BuildRequires:  libicu-devel
22 BuildRequires:  libmspack-devel
23 BuildRequires:  libparserutils-devel
24 BuildRequires:  librevenge-devel >= 0.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libwapcaplet-devel
27 BuildRequires:  libxml2-devel >= 2.0
28 BuildRequires:  pkgconfig >= 1:0.20
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  zlib-devel
32 Requires:       libCSS >= 0.3.0
33 Requires:       libhubbub >= 0.3.0
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libe-book is a library and a set of tools for reading and converting
38 various non-HTML reflowable e-book formats.
39
40 Currently supported are:
41 - eReader .pdb
42 - FictionBook v. 2 (including zipped files)
43 - PalmDoc Ebook
44 - Plucker .pdb
45 - QiOO (mobile format, for java-enabled cellphones)
46 - TCR (simple compressed text format)
47 - TealDoc
48 - zTXT
49 - ZVR (simple compressed text format)
50
51 %description -l pl.UTF-8
52 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
53 różnych nie-HTML-owych, tekstowych formatów e-booków.
54
55 Obecnie obsługiwane są:
56 - eReader .pdb
57 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
58 - PalmDoc Ebook
59 - Plucker .pdb
60 - QiOO (format przenośny, dla telefonów z Javą)
61 - TCR (prosty skompresowany format tekstowy)
62 - TealDoc
63 - zTXT
64 - ZVR (prosty skompresowany format tekstowy)
65
66 %package devel
67 Summary:        Header files for libe-book library
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       libCSS-devel >= 0.3.0
72 Requires:       libhubbub-devel >= 0.3.0
73 Requires:       libicu-devel
74 Requires:       libmspack-devel
75 Requires:       librevenge-devel >= 0.0
76 Requires:       libstdc++-devel
77 Requires:       libxml2-devel >= 2.0
78 Requires:       zlib-devel
79
80 %description devel
81 Header files for libe-book library.
82
83 %description devel -l pl.UTF-8
84 Pliki nagłówkowe biblioteki libe-book.
85
86 %package static
87 Summary:        Static libe-book library
88 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91
92 %description static
93 Static libe-book library.
94
95 %description static -l pl.UTF-8
96 Statyczna biblioteka libe-book.
97
98 %package apidocs
99 Summary:        libe-book API documentation
100 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
101 Group:          Documentation
102
103 %description apidocs
104 API documentation for libe-book library.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API biblioteki libe-book.
108
109 %package tools
110 Summary:        Tools to transform e-books into other formats
111 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
112 Group:          Applications/Publishing
113 Requires:       %{name} = %{version}-%{release}
114
115 %description tools
116 Tools to transform e-books into other formats. Currently supported:
117 HTML, text, raw.
118
119 %description tools -l pl.UTF-8
120 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
121 obsługiwane są HTML, tekst i format surowy.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126
127 %build
128 %configure \
129         --enable-experimental \
130         --disable-silent-rules \
131         %{?with_static_libs:--enable-static}
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 # obsoleted by pkg-config
141 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
142 # packaged as %doc in -apidocs
143 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   -p /sbin/ldconfig
149 %postun -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS ChangeLog NEWS README TODO
154 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
156 %{_datadir}/libe-book
157
158 %files devel
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
161 %{_includedir}/libe-book-0.1
162 %{_pkgconfigdir}/libe-book-0.1.pc
163
164 %if %{with static_libs}
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libe-book-0.1.a
168 %endif
169
170 %files apidocs
171 %defattr(644,root,root,755)
172 %doc docs/doxygen/html/*
173
174 %files tools
175 %defattr(644,root,root,755)
176 %attr(755,root,root) %{_bindir}/ebook2html
177 %attr(755,root,root) %{_bindir}/ebook2raw
178 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.080407 seconds and 3 git commands to generate.