]> git.pld-linux.org Git - packages/libe-book.git/blob - libe-book.spec
- release 3 (by relup.sh)
[packages/libe-book.git] / libe-book.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Library and tools for reading and converting various non-HTML reflowable e-book formats
6 Summary(pl.UTF-8):      Biblioteka i narzedzia do odczytu i konwersji różnych formatów e-booków
7 Name:           libe-book
8 Version:        0.1.1
9 Release:        3
10 License:        LGPL v2.1+ or MPL v2.0+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libebook/%{name}-%{version}.tar.xz
13 # Source0-md5:  3a46f4dedaadd3f1548c4423a6cdaf25
14 Patch0:         %{name}-missing.patch
15 URL:            http://libebook.sourceforge.net/
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf
19 BuildRequires:  libCSS-devel >= 0.3.0
20 BuildRequires:  libhubbub-devel >= 0.3.0
21 BuildRequires:  libicu-devel
22 BuildRequires:  libmspack-devel
23 BuildRequires:  libparserutils-devel
24 BuildRequires:  librevenge-devel >= 0.0
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libwapcaplet-devel
27 BuildRequires:  libxml2-devel >= 2.0
28 BuildRequires:  pkgconfig >= 1:0.20
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRequires:  zlib-devel
32 Requires:       libwpd >= 0.9.5
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 libe-book is a library and a set of tools for reading and converting
37 various non-HTML reflowable e-book formats.
38
39 Currently supported are:
40 - eReader .pdb
41 - FictionBook v. 2 (including zipped files)
42 - PalmDoc Ebook
43 - Plucker .pdb
44 - QiOO (mobile format, for java-enabled cellphones)
45 - TCR (simple compressed text format)
46 - TealDoc
47 - zTXT
48 - ZVR (simple compressed text format)
49
50 %description -l pl.UTF-8
51 libe-book to biblioteka i zestaw narzędzi do odczytu i konwersji
52 różnych nie-HTML-owych, tekstowych formatów e-booków.
53
54 Obecnie obsługiwane są:
55 - eReader .pdb
56 - FictionBook w wersji 2 (wraz z plikami skompresowanymi zipem)
57 - PalmDoc Ebook
58 - Plucker .pdb
59 - QiOO (format przenośny, dla telefonów z Javą)
60 - TCR (prosty skompresowany format tekstowy)
61 - TealDoc
62 - zTXT
63 - ZVR (prosty skompresowany format tekstowy)
64
65 %package devel
66 Summary:        Header files for libe-book library
67 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libe-book
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       libCSS-devel >= 0.3.0
71 Requires:       libhubbub-devel >= 0.3.0
72 Requires:       libicu-devel
73 Requires:       libmspack-devel
74 Requires:       librevenge-devel >= 0.0
75 Requires:       libstdc++-devel
76 Requires:       libxml2-devel >= 2.0
77 Requires:       zlib-devel
78
79 %description devel
80 Header files for libe-book library.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe biblioteki libe-book.
84
85 %package static
86 Summary:        Static libe-book library
87 Summary(pl.UTF-8):      Statyczna biblioteka libe-book
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static libe-book library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka libe-book.
96
97 %package apidocs
98 Summary:        libe-book API documentation
99 Summary(pl.UTF-8):      Dokumentacja API biblioteki libe-book
100 Group:          Documentation
101
102 %description apidocs
103 API documentation for libe-book library.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API biblioteki libe-book.
107
108 %package tools
109 Summary:        Tools to transform e-books into other formats
110 Summary(pl.UTF-8):      Programy przekształcania e-booków do innych formatów
111 Group:          Applications/Publishing
112 Requires:       %{name} = %{version}-%{release}
113
114 %description tools
115 Tools to transform e-books into other formats. Currently supported:
116 HTML, text, raw.
117
118 %description tools -l pl.UTF-8
119 Narzędzia do przekształcania e-booków do innych formatów. Aktualnie
120 obsługiwane są HTML, tekst i format surowy.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125
126 %build
127 %configure \
128         --enable-experimental \
129         --disable-silent-rules \
130         %{?with_static_libs:--enable-static}
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 # obsoleted by pkg-config
140 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libe-book-*.la
141 # packaged as %doc in -apidocs
142 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libe-book
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README TODO
153 %attr(755,root,root) %{_libdir}/libe-book-0.1.so.*.*.*
154 %attr(755,root,root) %ghost %{_libdir}/libe-book-0.1.so.1
155 %{_datadir}/libe-book
156
157 %files devel
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libe-book-0.1.so
160 %{_includedir}/libe-book-0.1
161 %{_pkgconfigdir}/libe-book-0.1.pc
162
163 %if %{with static_libs}
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libe-book-0.1.a
167 %endif
168
169 %files apidocs
170 %defattr(644,root,root,755)
171 %doc docs/doxygen/html/*
172
173 %files tools
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{_bindir}/ebook2html
176 %attr(755,root,root) %{_bindir}/ebook2raw
177 %attr(755,root,root) %{_bindir}/ebook2text
This page took 0.09023 seconds and 3 git commands to generate.