]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
- added bcond_without static_libs
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4 %{x8664}
8 %define         with_mmx        1
9 %endif
10 Summary:        DV video software codec
11 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
12 Name:           libdv
13 Version:        0.104
14 Release:        1
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
18 # Source0-md5:  f6b08efce7472daa20685e6e8431f542
19 Patch0:         %{name}-include_fix.patch
20 URL:            http://libdv.sourceforge.net/
21 %if %{with gui}
22 BuildRequires:  SDL-devel >= 1.1.6
23 BuildRequires:  XFree86-devel
24 BuildRequires:  gtk+-devel >= 1.2.10-3
25 %endif
26 BuildRequires:  pkgconfig >= 1:0.7
27 BuildRequires:  popt-devel
28 BuildRequires:  rpmbuild(macros) >= 1.213
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The Quasar DV codec (libdv) is a software codec for DV video. DV is
33 the encoding format used by most digital camcorders, typically those
34 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
35 was developed according to the official standards for DV video, IEC
36 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
37
38 %description -l pl
39 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
40 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
41 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
42 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
43
44 %package -n dv
45 Summary:        Programs to encode and play DV files
46 Summary(pl):    Programy do kodowania i odtwarzania plików DV
47 Group:          X11/Applications/Multimedia
48 Requires:       %{name} = %{version}-%{release}
49
50 %description -n dv
51 Programs to encode and play DV files.
52
53 %description -n dv -l pl
54 Programy do kodowania i odtwarzania plików DV.
55
56 %package devel
57 Summary:        DV library headers
58 Summary(pl):    Pliki nag³ówkowe biblioteki DV
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 This is the libraries, include files and other resources you can use
64 to incorporate libdv into applications.
65
66 %description devel -l pl
67 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
68 libdv.
69
70 %package static
71 Summary:        DV static libraries
72 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 This is package with static libdv libraries.
78
79 %description static -l pl
80 Statyczna wersja biblioteki libdv.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %build
87 %configure \
88         --enable-shared \
89 %if %{with gui}
90         --enable-sdl \
91         --enable-gtk \
92 %else
93         --disable-sdl \
94         --disable-gtk \
95 %endif
96         --without-debug \
97         %{!?with_mmx:--disable-asm} \
98         %{!?with_static_libs:--disable-static}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT \
107         pkgconfigdir=%{_pkgconfigdir}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS ChangeLog NEWS README.* TODO
118 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
119
120 %if %{with gui}
121 %files -n dv
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/*
124 %{_mandir}/man1/*
125 %endif
126
127 %files devel
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/lib*.so
130 %{_libdir}/*.la
131 %{_includedir}/libdv
132 %{_pkgconfigdir}/*
133
134 %if %{with static_libs}
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
138 %endif
This page took 0.056045 seconds and 4 git commands to generate.