]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
- unified spacing
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 #
6 %ifarch athlon pentium3 pentium4
7 %define         with_mmx        1
8 %endif
9 Summary:        DV video software codec
10 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
11 Name:           libdv
12 Version:        0.103
13 Release:        2
14 License:        LGPL
15 Group:          Libraries
16 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
17 # Source0-md5:  b5c7d0db672a76528e100828dd866a79
18 Patch0:         %{name}-include_fix.patch
19 URL:            http://libdv.sourceforge.net/
20 %if %{with gui}
21 BuildRequires:  SDL-devel
22 BuildRequires:  XFree86-devel
23 BuildRequires:  gtk+-devel >= 1.2.10-3
24 %endif
25 BuildRequires:  pkgconfig >= 0.7
26 BuildRequires:  popt-devel
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The Quasar DV codec (libdv) is a software codec for DV video. DV is
31 the encoding format used by most digital camcorders, typically those
32 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
33 was developed according to the official standards for DV video, IEC
34 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
35
36 %description -l pl
37 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
38 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
39 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
40 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
41
42 %package -n dv
43 Summary:        Programs to encode and play DV files
44 Summary(pl):    Programy do kodowania i odtwarzania plików DV
45 Group:          X11/Applications/Multimedia
46 Requires:       %{name} = %{version}-%{release}
47
48 %description -n dv
49 Programs to encode and play DV files.
50
51 %description -n dv -l pl
52 Programy do kodowania i odtwarzania plików DV.
53
54 %package devel
55 Summary:        DV library headers
56 Summary(pl):    Pliki nag³ówkowe biblioteki DV
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59
60 %description devel
61 This is the libraries, include files and other resources you can use
62 to incorporate libdv into applications.
63
64 %description devel -l pl
65 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
66 libdv.
67
68 %package static
69 Summary:        DV static libraries
70 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
71 Group:          Development/Libraries
72 Requires:       %{name}-devel = %{version}-%{release}
73
74 %description static
75 This is package with static libdv libraries.
76
77 %description static -l pl
78 Statyczna wersja biblioteki libdv.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83
84 %build
85 %configure \
86         --enable-shared \
87 %if %{with gui}
88         --enable-sdl \
89         --enable-gtk \
90 %else
91         --disable-sdl \
92         --disable-gtk \
93 %endif
94         --without-debug \
95         %{!?with_mmx:--disable-asm}
96
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT \
104         pkgconfigdir=%{_pkgconfigdir}
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README.* TODO
115 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
116
117 %if %{with gui}
118 %files -n dv
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/*
121 %{_mandir}/man1/*
122 %endif
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_libdir}/*.la
128 %{_includedir}/libdv
129 %{_pkgconfigdir}/*
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
This page took 0.037823 seconds and 4 git commands to generate.