]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
- release 3.
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4
8 # %{x8664} skipped - gas generates PIC-incompatible relocation entries
9 %define         with_mmx        1
10 %endif
11 Summary:        DV video software codec
12 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
13 Name:           libdv
14 Version:        0.104
15 Release:        3
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
19 # Source0-md5:  f6b08efce7472daa20685e6e8431f542
20 Patch0:         %{name}-include_fix.patch
21 Patch1:         %{name}-mmx.patch
22 URL:            http://libdv.sourceforge.net/
23 %if %{with gui}
24 BuildRequires:  SDL-devel >= 1.1.6
25 BuildRequires:  XFree86-devel
26 BuildRequires:  gtk+-devel >= 1.2.10-3
27 %endif
28 BuildRequires:  automake
29 BuildRequires:  pkgconfig >= 1:0.7
30 BuildRequires:  popt-devel
31 BuildRequires:  rpmbuild(macros) >= 1.213
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Quasar DV codec (libdv) is a software codec for DV video. DV is
36 the encoding format used by most digital camcorders, typically those
37 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
38 was developed according to the official standards for DV video, IEC
39 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
40
41 %description -l pl
42 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
43 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
44 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
45 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
46
47 %package -n dv
48 Summary:        Programs to encode and play DV files
49 Summary(pl):    Programy do kodowania i odtwarzania plików DV
50 Group:          X11/Applications/Multimedia
51 Requires:       %{name} = %{version}-%{release}
52
53 %description -n dv
54 Programs to encode and play DV files.
55
56 %description -n dv -l pl
57 Programy do kodowania i odtwarzania plików DV.
58
59 %package devel
60 Summary:        DV library headers
61 Summary(pl):    Pliki nag³ówkowe biblioteki DV
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64
65 %description devel
66 This is the libraries, include files and other resources you can use
67 to incorporate libdv into applications.
68
69 %description devel -l pl
70 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
71 libdv.
72
73 %package static
74 Summary:        DV static libraries
75 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 This is package with static libdv libraries.
81
82 %description static -l pl
83 Statyczna wersja biblioteki libdv.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 cp /usr/share/automake/config.sub .
92 %configure \
93         --enable-shared \
94 %if %{with gui}
95         --enable-sdl \
96         --enable-gtk \
97 %else
98         --disable-sdl \
99         --disable-gtk \
100 %endif
101         --without-debug \
102         %{!?with_mmx:--disable-asm} \
103         %{!?with_static_libs:--disable-static}
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT \
112         pkgconfigdir=%{_pkgconfigdir}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS ChangeLog NEWS README.* TODO
123 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
124
125 %if %{with gui}
126 %files -n dv
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/*
129 %{_mandir}/man1/*
130 %endif
131
132 %files devel
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/lib*.so
135 %{_libdir}/*.la
136 %{_includedir}/libdv
137 %{_pkgconfigdir}/*
138
139 %if %{with static_libs}
140 %files static
141 %defattr(644,root,root,755)
142 %{_libdir}/lib*.a
143 %endif
This page took 0.044103 seconds and 4 git commands to generate.