]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
- fPIC
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4 %{x8664}
8 %define         with_mmx        1
9 %endif
10 Summary:        DV video software codec
11 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
12 Name:           libdv
13 Version:        0.104
14 Release:        2
15 License:        LGPL
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
18 # Source0-md5:  f6b08efce7472daa20685e6e8431f542
19 Patch0:         %{name}-include_fix.patch
20 URL:            http://libdv.sourceforge.net/
21 %if %{with gui}
22 BuildRequires:  SDL-devel >= 1.1.6
23 BuildRequires:  XFree86-devel
24 BuildRequires:  gtk+-devel >= 1.2.10-3
25 %endif
26 BuildRequires:  automake
27 BuildRequires:  pkgconfig >= 1:0.7
28 BuildRequires:  popt-devel
29 BuildRequires:  rpmbuild(macros) >= 1.213
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 The Quasar DV codec (libdv) is a software codec for DV video. DV is
34 the encoding format used by most digital camcorders, typically those
35 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
36 was developed according to the official standards for DV video, IEC
37 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
38
39 %description -l pl
40 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
41 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
42 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
43 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
44
45 %package -n dv
46 Summary:        Programs to encode and play DV files
47 Summary(pl):    Programy do kodowania i odtwarzania plików DV
48 Group:          X11/Applications/Multimedia
49 Requires:       %{name} = %{version}-%{release}
50
51 %description -n dv
52 Programs to encode and play DV files.
53
54 %description -n dv -l pl
55 Programy do kodowania i odtwarzania plików DV.
56
57 %package devel
58 Summary:        DV library headers
59 Summary(pl):    Pliki nag³ówkowe biblioteki DV
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 This is the libraries, include files and other resources you can use
65 to incorporate libdv into applications.
66
67 %description devel -l pl
68 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
69 libdv.
70
71 %package static
72 Summary:        DV static libraries
73 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 This is package with static libdv libraries.
79
80 %description static -l pl
81 Statyczna wersja biblioteki libdv.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86
87 %build
88 cp /usr/share/automake/config.sub .
89 CFLAGS="%{rpmcflags} -fPIC"
90 %configure \
91         --enable-shared \
92 %if %{with gui}
93         --enable-sdl \
94         --enable-gtk \
95 %else
96         --disable-sdl \
97         --disable-gtk \
98 %endif
99         --without-debug \
100         %{!?with_mmx:--disable-asm} \
101         %{!?with_static_libs:--disable-static}
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT \
110         pkgconfigdir=%{_pkgconfigdir}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS ChangeLog NEWS README.* TODO
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
122
123 %if %{with gui}
124 %files -n dv
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man1/*
128 %endif
129
130 %files devel
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %{_libdir}/*.la
134 %{_includedir}/libdv
135 %{_pkgconfigdir}/*
136
137 %if %{with static_libs}
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/lib*.a
141 %endif
This page took 0.042891 seconds and 4 git commands to generate.