]> git.pld-linux.org Git - packages/libdv.git/blob - libdv.spec
74aaa60690c123add142dfb2cc02bcd3b0fec3e3
[packages/libdv.git] / libdv.spec
1 #
2 # Conditional build:
3 %bcond_without  gui     # don't build gui stuff
4 %bcond_with     mmx     # use MMX asm (won't run on non-MMX CPU!)
5 %bcond_without  static_libs     # don't build static library
6 #
7 %ifarch athlon pentium3 pentium4
8 # %{x8664} skipped - gas generates PIC-incompatible relocation entries
9 %define         with_mmx        1
10 %endif
11 Summary:        DV video software codec
12 Summary(pl):    Biblioteka do obs³ugi formatu wideo DV
13 Name:           libdv
14 Version:        0.104
15 Release:        3
16 License:        LGPL
17 Group:          Libraries
18 Source0:        http://dl.sourceforge.net/libdv/%{name}-%{version}.tar.gz
19 # Source0-md5:  f6b08efce7472daa20685e6e8431f542
20 Patch0:         %{name}-include_fix.patch
21 Patch1:         %{name}-mmx.patch
22 URL:            http://libdv.sourceforge.net/
23 %if %{with gui}
24 BuildRequires:  SDL-devel >= 1.1.6
25 BuildRequires:  XFree86-devel
26 BuildRequires:  gtk+-devel >= 1.2.10-3
27 %endif
28 BuildRequires:  autoconf
29 BuildRequires:  automake
30 BuildRequires:  libtool
31 BuildRequires:  pkgconfig >= 1:0.7
32 BuildRequires:  popt-devel
33 BuildRequires:  rpmbuild(macros) >= 1.213
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 The Quasar DV codec (libdv) is a software codec for DV video. DV is
38 the encoding format used by most digital camcorders, typically those
39 that support the IEEE 1394 (aka FireWire or i.Link) interface. libdv
40 was developed according to the official standards for DV video, IEC
41 61834 and SMPTE 314M. See http://libdv.sourceforge.net/ for more.
42
43 %description -l pl
44 Quasar DV (libdv) jest bibliotek± do obs³ugi obrazu DV. DV jest
45 formatem stosowanym przez wiêkszo¶æ cyfrowych urz±dzeñ, zwykle tych,
46 które u¿ywaj± interfejsu IEEE 1394 (FireWire/i.Link). libdv jest
47 pisany zgodnie z oficjalnymi standardami DV, IEC 61834, SMPTE 314M.
48
49 %package -n dv
50 Summary:        Programs to encode and play DV files
51 Summary(pl):    Programy do kodowania i odtwarzania plików DV
52 Group:          X11/Applications/Multimedia
53 Requires:       %{name} = %{version}-%{release}
54
55 %description -n dv
56 Programs to encode and play DV files.
57
58 %description -n dv -l pl
59 Programy do kodowania i odtwarzania plików DV.
60
61 %package devel
62 Summary:        DV library headers
63 Summary(pl):    Pliki nag³ówkowe biblioteki DV
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description devel
68 This is the libraries, include files and other resources you can use
69 to incorporate libdv into applications.
70
71 %description devel -l pl
72 Pliki nag³ówkowe potrzebne do budowania programów korzystaj±cych z
73 libdv.
74
75 %package static
76 Summary:        DV static libraries
77 Summary(pl):    Statyczne biblioteki do obs³ugi formatu DV
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 This is package with static libdv libraries.
83
84 %description static -l pl
85 Statyczna wersja biblioteki libdv.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91
92 %build
93 cp /usr/share/automake/config.sub .
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         --enable-shared \
100 %if %{with gui}
101         --enable-sdl \
102         --enable-gtk \
103 %else
104         --disable-sdl \
105         --disable-gtk \
106 %endif
107         --without-debug \
108         %{!?with_mmx:--disable-asm} \
109         %{!?with_static_libs:--disable-static}
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT \
118         pkgconfigdir=%{_pkgconfigdir}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog NEWS README.* TODO
129 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
130
131 %if %{with gui}
132 %files -n dv
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_bindir}/*
135 %{_mandir}/man1/*
136 %endif
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/lib*.so
141 %{_libdir}/*.la
142 %{_includedir}/libdv
143 %{_pkgconfigdir}/*
144
145 %if %{with static_libs}
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/lib*.a
149 %endif
This page took 0.038155 seconds and 3 git commands to generate.