]> git.pld-linux.org Git - SPECS.git/blob - libdts.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libdts.spec
1 # TODO: rename spec to libdca, swap Name/Provides?
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        DTS Coherent Acoustics streams decoder
7 Summary(pl.UTF-8):      Dekoder strumieni DTS Coherent Acoustics
8 Name:           libdts
9 Version:        0.0.7
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://download.videolan.org/pub/videolan/libdca/%{version}/libdca-%{version}.tar.bz2
14 # Source0-md5:  68916db60e3017d92841f77908518a11
15 Patch0:         %{name}-opt.patch
16 Patch1:         %{name}-link.patch
17 URL:            http://www.videolan.org/developers/libdca.html
18 BuildRequires:  autoconf >= 2.54
19 BuildRequires:  automake >= 1.5
20 BuildRequires:  libtool
21 BuildRequires:  rpmbuild(macros) >= 1.402
22 Provides:       libdca = %{version}-%{release}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         specflags       -fno-strict-aliasing
26
27 %description
28 Free decoder for the DTS Coherent Acoustics format. It consists of a
29 library and a command line decoder. DTS is a high quality
30 multi-channel (5.1) digital audio format used in DVDs and DTS audio
31 CDs.
32
33 %description -l pl.UTF-8
34 Wolnodostępny dekoder formatu DTS Coherent Acoustics. Składa się z
35 biblioteki i dekodera działającego z linii poleceń. DTS jest wysokiej
36 jakości wielokanałowym (5.1) cyfrowym formatem audio używanym w DVD i
37 DTS audio CD.
38
39 %package devel
40 Summary:        Header files for libdca library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdca
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Provides:       libdca-devel = %{version}-%{release}
45
46 %description devel
47 Header files for libdca library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libdca.
51
52 %package static
53 Summary:        Static libdca library
54 Summary(pl.UTF-8):      Statyczna biblioteka libdca
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57 Provides:       libdca-static = %{version}-%{release}
58
59 %description static
60 Static libdca library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libdca.
64
65 %package tools
66 Summary:        DTS Coherent Acoustics streams decoder tools
67 Summary(pl.UTF-8):      Narzędzia dekodera strumieni DTS Coherent Acoustics
68 Group:          Applications/Sound
69 Requires:       %{name} = %{version}-%{release}
70 Provides:       libdca-tools = %{version}-%{release}
71
72 %description tools
73 DTS Coherent Acoustics streams decoder tools.
74
75 %description tools -l pl.UTF-8
76 Narzędzia dekodera strumieni DTS Coherent Acoustics.
77
78 %prep
79 %setup -q -n libdca-%{version}
80 %patch0 -p1
81 %patch1 -p1
82
83 %build
84 %{__libtoolize}
85 %{__aclocal} -I m4
86 %{__autoconf}
87 %{__autoheader}
88 %{__automake}
89 %configure \
90         %{!?with_static_libs:--disable-static}
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # obsoleted by pkg-config
100 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdca.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS ChangeLog NEWS README TODO
111 %attr(755,root,root) %{_libdir}/libdca.so.*.*.*
112 %attr(755,root,root) %ghost %{_libdir}/libdca.so.0
113
114 %files devel
115 %defattr(644,root,root,755)
116 %doc doc/libdca.txt
117 %attr(755,root,root) %{_libdir}/libdca.so
118 %{_includedir}/dca.h
119 %{_includedir}/dts.h
120 %{_pkgconfigdir}/libdca.pc
121 %{_pkgconfigdir}/libdts.pc
122
123 %if %{with static_libs}
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libdca.a
127 %{_libdir}/libdts.a
128 %endif
129
130 %files tools
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/dcadec
133 %attr(755,root,root) %{_bindir}/dtsdec
134 %attr(755,root,root) %{_bindir}/extract_dca
135 %attr(755,root,root) %{_bindir}/extract_dts
136 %{_mandir}/man1/dcadec.1*
137 %{_mandir}/man1/dtsdec.1*
138 %{_mandir}/man1/extract_dca.1*
139 %{_mandir}/man1/extract_dts.1*
This page took 0.237826 seconds and 3 git commands to generate.