]> git.pld-linux.org Git - packages/libdsk.git/blob - libdsk.spec
- updated to 1.4.2
[packages/libdsk.git] / libdsk.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 %bcond_without  java            # Java binding
5 #
6 Summary:        libdsk library
7 Summary(pl.UTF-8):      Biblioteka libdsk
8 Name:           libdsk
9 # note: 1.4.x is stable, 1.5.x development version
10 Version:        1.4.2
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        http://www.seasip.info/Unix/LibDsk/%{name}-%{version}.tar.gz
15 # Source0-md5:  9e1128a423069528c90a647f69284792
16 Patch0:         %{name}-am.patch
17 Patch1:         %{name}-java.patch
18 URL:            http://www.seasip.info/Unix/LibDsk/
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel
22 %{?with_java:BuildRequires:     jdk}
23 BuildRequires:  libtool >= 2:2
24 BuildRequires:  sed >= 4.0
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 LibDsk is a library intended to give transparent access to floppy
30 drives and to the "disc image files" used by emulators to represent
31 floppy drives.
32
33 %description -l pl.UTF-8
34 LibDsk jest biblioteką, która w sposób przezroczysty daje dostęp do
35 "obrazów dysków" używanych przez emulatory do reprezentowania dysków
36 elastycznych.
37
38 %package devel
39 Summary:        libdsk library - development files
40 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libdsk
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       bzip2-devel
44 Requires:       zlib-devel
45
46 %description devel
47 The libdsk-devel package contains the header files and documentation
48 needed to develop applications with libdsk.
49
50 %description devel -l pl.UTF-8
51 Pakiet libdsk-devel zawiera pliki nagłówkowe i dokumentację potrzebne
52 do kompilowania aplikacji korzystających z libdsk.
53
54 %package static
55 Summary:        libdsk static library
56 Summary(pl.UTF-8):      Statyczna biblioteka libdsk
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 This package contains the static libdsk library.
62
63 %description static -l pl.UTF-8
64 Statyczna wersja biblioteki libdsk.
65
66 %package -n java-libdsk
67 Summary:        Java interface to libdsk library
68 Summary(pl.UTF-8):      Interfejs Javy do biblioteki libdsk
69 Group:          Libraries/Java
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       jre
72
73 %description -n java-libdsk
74 Java interface to libdsk library.
75
76 %description -n java-libdsk -l pl.UTF-8
77 Interfejs Javy do biblioteki libdsk.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 %{__sed} -i -e 's,/usr/local/share,%{_datadir},' man/libdskrc.5
85
86 # avoid lyx BR
87 touch -r doc/libdsk.lyx doc/libdsk.txt
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 # - ac_cv_prog_uudecode_base64=no is a workaround to enforce
96 #   Test.class recompilation (included version doesn't work with JDK 1.6);
97 # - check needs . in CLASSPATH
98 # - we redefine --datadir because global config file is %{_datadir}/LibDsk/libdskrc
99 export CLASSPATH=.
100 %configure \
101         ac_cv_prog_uudecode_base64=no \
102         --datadir=%{_sysconfdir} \
103         %{!?with_static_libs:--disable-static} \
104         %{?with_java:--with-jni}
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 install -D doc/libdskrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/LibDsk/libdskrc
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc ChangeLog TODO
124 %attr(755,root,root) %{_bindir}/apriboot
125 %attr(755,root,root) %{_bindir}/dsk*
126 %attr(755,root,root) %{_bindir}/md3serial
127 %attr(755,root,root) %{_libdir}/libdsk.so.*.*.*
128 %attr(755,root,root) %ghost %{_libdir}/libdsk.so.3
129 %dir %{_sysconfdir}/LibDsk
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/LibDsk/libdskrc
131 %{_mandir}/man1/apriboot.1*
132 %{_mandir}/man1/dsk*.1*
133 %{_mandir}/man1/md3serial.1*
134 %{_mandir}/man5/libdskrc.5*
135
136 %files devel
137 %defattr(644,root,root,755)
138 %doc doc/{libdsk.txt,cfi.html,TODO}
139 %attr(755,root,root) %{_libdir}/libdsk.so
140 %{_libdir}/libdsk.la
141 %{_includedir}/libdsk.h
142
143 %if %{with static_libs}
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/libdsk.a
147 %endif
148
149 %if %{with java}
150 %files -n java-libdsk
151 %defattr(644,root,root,755)
152 %{_javadir}/libdsk.jar
153 %endif
This page took 0.054354 seconds and 4 git commands to generate.