]> git.pld-linux.org Git - SPECS.git/blob - libdmapsharing.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libdmapsharing.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_with     check           # check/testing support (note: library links with libcheck!)
5 %bcond_without  static_libs     # static library build
6
7 Summary:        A DMAP client and server library
8 Summary(pl.UTF-8):      Biblioteka klienta i serwera DMAP
9 Name:           libdmapsharing
10 Version:        3.9.10
11 Release:        1
12 License:        LGPL v2.1+
13 Group:          Libraries
14 Source0:        https://www.flyn.org/projects/libdmapsharing/%{name}-%{version}.tar.gz
15 # Source0-md5:  6286e01ba3f628f4b85e05a55a391621
16 Patch0:         floorf.patch
17 URL:            https://www.flyn.org/projects/libdmapsharing/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  avahi-glib-devel >= 0.6
21 %{?with_check:BuildRequires:    check-devel >= 0.12}
22 BuildRequires:  gdk-pixbuf2-devel >= 2.0
23 BuildRequires:  glib2-devel >= 1:2.40
24 BuildRequires:  gobject-introspection-devel >= 1.30.0
25 BuildRequires:  gstreamer-plugins-base-devel >= 1.0
26 BuildRequires:  gtk-doc >= 1.0
27 # noinst programs only
28 #BuildRequires: gtk+3-devel >= 3.0
29 #BuildRequires: libgee-devel >= 0.8
30 BuildRequires:  libsoup-devel >= 2.48.0
31 BuildRequires:  libtool
32 BuildRequires:  pkgconfig
33 # not needed for releases, noinst only
34 #BuildRequires: vala >= 1:0.11.4
35 BuildRequires:  zlib-devel
36 Requires:       avahi-glib >= 0.6
37 Requires:       glib2 >= 1:2.40
38 Requires:       libsoup >= 2.48.0
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 libdmapsharing is a library you may use to access and share DMAP (DAAP
43 & DPAP) content. The library is written in C using GObject and
44 libsoup.
45
46 The DMAP family of protocols are used by products such as iTunes(TM),
47 iPhoto(TM) and the Roku SoundBridge(TM) family to share content such
48 as music and photos.
49
50 %description -l pl.UTF-8
51 libdmapsharing to biblioteka służąca do dostępu i współdzielenia
52 treści DMAP (DAAP i DPAP). Biblioteka jest napisana w C z użyciem
53 bibliotek GObject i libsoup.
54
55 Rodzina protokołów DMAP jest wykorzystywana przez produkty takie jak
56 iTunes(TM), iPhoto(TM) oraz Roku SoundBridge do współdzielenia treści
57 takich jak muzyka czy zdjęcia.
58
59 %package devel
60 Summary:        Files needed to develop applications using libdmapsharing
61 Summary(pl.UTF-8):      Pliki niezbędne do tworzenia aplikacji wykorzystujących libdmapsharing
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       avahi-glib-devel >= 0.6
65 Requires:       gdk-pixbuf2-devel >= 2.0
66 Requires:       glib2-devel >= 1:2.40
67 Requires:       gstreamer-plugins-base-devel >= 1.0
68 Requires:       libsoup-devel >= 2.32.2
69
70 %description devel
71 libdmapsharing implements the DMAP protocols. This includes support
72 for DAAP and DPAP. This package provides the include files and other
73 resources needed for developing applications using libdmapsharing.
74
75 %description devel -l pl.UTF-8
76 libdmapsharing implementuje protokoły DMAP. Obejmuje obsługę DAAP i
77 DPAP. Ten pakiet zawiera pliki nagłówkowe i inne niezbędne do
78 tworzenia aplikacji wykorzystujących libdmapsharing.
79
80 %package static
81 Summary:        Static libdmapsharing library
82 Summary(pl.UTF-8):      Statyczna biblioteka libdmapsharing
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static libdmapsharing library.
88
89 %description static -l pl.UTF-8
90 Statyczna biblioteka libdmapsharing.
91
92 %package apidocs
93 Summary:        libdmapsharing API documentation
94 Summary(pl.UTF-8):      Dokumentacja API biblioteki libdmapsharing
95 Group:          Documentation
96 BuildArch:      noarch
97
98 %description apidocs
99 API documentation for libdmapsharing library.
100
101 %description apidocs -l pl.UTF-8
102 Dokumentacja API biblioteki libdmapsharing.
103
104 %package -n vala-libdmapsharing
105 Summary:        Vala API for libdmapsharing library
106 Summary(pl.UTF-8):      API języka Vala do biblioteki libdmapsharing
107 Group:          Development/Libraries
108 Requires:       %{name}-devel = %{version}-%{release}
109 Requires:       vala >= 1:0.11.4
110 BuildArch:      noarch
111
112 %description -n vala-libdmapsharing
113 Vala API for libdmapsharing library.
114
115 %description -n vala-libdmapsharing -l pl.UTF-8
116 API języka Vala do biblioteki libdmapsharing.
117
118 %prep
119 %setup -q
120 %patch0 -p1
121
122 %build
123 %{__libtoolize}
124 %{__aclocal} -I m4
125 %{__autoconf}
126 %{__autoheader}
127 %{__automake}
128 %configure \
129         %{!?with_check:--disable-check} \
130         --disable-silent-rules \
131         %{?with_static_libs:--enable-static} \
132         %{!?with_check:--disable-tests} \
133         --with-html-dir=%{_gtkdocdir} \
134         --with-mdns=avahi
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         INSTALL="install -p" \
143         DESTDIR=$RPM_BUILD_ROOT
144
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdmapsharing-4.0.la
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   -p /sbin/ldconfig
151 %postun -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README README-Memory TODO
156 %attr(755,root,root) %{_libdir}/libdmapsharing-4.0.so.*.*.*
157 %attr(755,root,root) %ghost %{_libdir}/libdmapsharing-4.0.so.3
158 %{_libdir}/girepository-1.0/Dmap-4.0.typelib
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libdmapsharing-4.0.so
163 %{_includedir}/libdmapsharing-4.0
164 %{_datadir}/gir-1.0/Dmap-4.0.gir
165 %{_pkgconfigdir}/libdmapsharing-4.0.pc
166
167 %if %{with static_libs}
168 %files static
169 %defattr(644,root,root,755)
170 %{_libdir}/libdmapsharing-4.0.a
171 %endif
172
173 %if %{with apidocs}
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/libdmapsharing-4.0
177 %endif
178
179 %files -n vala-libdmapsharing
180 %defattr(644,root,root,755)
181 %{_datadir}/vala/vapi/libdmapsharing-4.0.vapi
This page took 0.946883 seconds and 3 git commands to generate.