]> git.pld-linux.org Git - SPECS.git/blob - libdc1394.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libdc1394.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 %bcond_with     v4l1            # build with Video4Linux 1.x API (dropped in linux kernel 2.6.38)
5
6 Summary:        Library for 1394 Digital Camera Specification
7 Summary(pl.UTF-8):      Biblioteka dla specyfikacji kamery cyfrowej 1394 (1394 Digital Camera)
8 Name:           libdc1394
9 Version:        2.2.6
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libdc1394/%{name}-%{version}.tar.gz
14 # Source0-md5:  9fad67bbff08fe2818d5ec81802ec89f
15 Patch0:         %{name}-link.patch
16 Patch1:         %{name}-ac.patch
17 # libdc1394-2.1.2 vs libdc1394_avt-2.1.2 diff (http://www.alliedvisiontec.com/fileadmin/content/PDF/Software/AVT_software/zip_files/AVTFire4Linux3v0.src.tar/libdc1394_avt-2.1.2.tar.gz)
18 Patch2:         %{name}-avt.patch
19 URL:            http://damien.douxchamps.net/ieee1394/libdc1394/
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  SDL-devel >= 1.2.4
22 BuildRequires:  autoconf >= 2.60
23 BuildRequires:  automake >= 1:1.9.6
24 BuildRequires:  libraw1394-devel >= 1.2.0
25 BuildRequires:  libtool
26 BuildRequires:  libusb-devel >= 1.0
27 %{?with_v4l1:BuildRequires:     linux-libc-headers < 7:2.6.38}
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpmbuild(macros) >= 1.583
30 BuildRequires:  xorg-lib-libX11-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXv-devel
33 Requires:       SDL >= 1.2.4
34 Requires:       libraw1394 >= 1.2.0
35 Requires:       libusb >= 1.0
36 Provides:       libdc1394(avt) = %{version}-%{release}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 libdc1394 is a library that is intended to provide a high level
41 programming interface for application developers who wish to control
42 IEEE 1394 based cameras that conform to the 1394-based Digital Camera
43 Specification (found at http://www.1394ta.org/).
44
45 %description -l pl.UTF-8
46 libdc1394 jest biblioteką, której założeniem jest dostarczenie
47 interfejsu wysokiego poziomu dla twórców oprogramowania pragnących
48 sterować kamerami skonstruowanymi w oparciu o IEEE 1394 zgodnie ze
49 specyfikacją kamery cyfrowej 1394 (1394 Digital Camera, dostępną pod
50 http://www.1394ta.org/).
51
52 %package devel
53 Summary:        libdc1394 header files
54 Summary(pl.UTF-8):      Pliki nagłówkowe libdc1394
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       libraw1394-devel >= 1.2.0
58 Requires:       libusb-devel >= 1.0
59 Provides:       libdc1394-devel(avt) = %{version}-%{release}
60
61 %description devel
62 libdc1394 header files.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe libdc1394.
66
67 %package static
68 Summary:        Static libdc1394 library
69 Summary(pl.UTF-8):      Statyczna biblioteka libdc1394
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72 Provides:       libdc1394-static(avt) = %{version}-%{release}
73
74 %description static
75 Static libdc1394 library.
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka libdc1394.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85
86 %build
87 %{__libtoolize}
88 %{__aclocal}
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         %{!?with_static_libs:--disable-static}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 # man pages for noinst examples
103 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{dc1394_multiview,grab_{color,gray,partial}_image}.1
104 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/avt_singleview.1
105
106 %if %{without v4l1}
107 # dc1394_vloopback not built if !HAVE_VIDEODEV, remove man page as well
108 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/dc1394_vloopback.1
109 %endif
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %doc AUTHORS ChangeLog NEWS README
120 %attr(755,root,root) %{_bindir}/dc1394_reset_bus
121 %attr(755,root,root) %{_libdir}/libdc1394.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libdc1394.so.25
123 %{_mandir}/man1/dc1394_reset_bus.1*
124 %if %{with v4l1}
125 %attr(755,root,root) %{_bindir}/dc1394_vloopback
126 %{_mandir}/man1/dc1394_vloopback.1*
127 %endif
128
129 %files devel
130 %defattr(644,root,root,755)
131 %attr(755,root,root) %{_libdir}/libdc1394.so
132 %{_libdir}/libdc1394.la
133 %{_includedir}/dc1394
134 %{_pkgconfigdir}/libdc1394-2.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libdc1394.a
140 %endif
This page took 1.841603 seconds and 3 git commands to generate.