]> git.pld-linux.org Git - packages/libdbi-drivers.git/blob - libdbi-drivers.spec
a083196b9f3ba7beb3dcff95b161d50c4f0cee7e
[packages/libdbi-drivers.git] / libdbi-drivers.spec
1 %bcond_without mysql  # don't build mysql driver
2 %bcond_without pgsql  # don't build postgresql driver
3 %bcond_without sqlite # don't build sqlite driver
4 %define dbiver                  0.7.1
5 Summary:        Database Independent Abstraction Layer for C
6 Summary(pl):    Warstwa DBI dla C
7 Name:           libdbi-drivers
8 Version:        0.7.0
9 Release:        1
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/libdbi-drivers/libdbi-drivers-%{version}.tar.gz
13 # Source0-md5:  4a523d28b53934cdd6bf1fadf0bfc6b9
14 URL:            http://libdbi-drivers.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libtool
18 BuildRequires:  libdbi-devel >= %{dbiver}
19 %{?with_mysql:BuildRequires:    mysql-devel}
20 %{?with_pgsql:BuildRequires:    postgresql-devel}
21 %{?with_sqlite:BuildRequires:   sqlite-devel}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libdbi implements a database-independent abstraction layer in C,
26 similar to the DBI/DBD layer in Perl. Writing one generic set of code,
27 programmers can leverage the power of multiple databases and multiple
28 simultaneous database connections by using this framework.
29
30 %description -l pl
31 libdbi jest implementacj± w C warstwy abstrakcyjnej niezale¿nej od
32 bazy danych, podobnej do warstwy DBI/DBD w Perlu. U¿ywaj±c tego
33 ¶rodowiska programista mo¿e za pomoc± jednego, wspólnego kodu
34 odwo³ywaæ siê do wielu ró¿nych baz danych, tak¿e jednocze¶nie.
35
36 %package mysql
37 Summary:        MySQL plugin for libdbi
38 Summary(pl):    Wtyczka MySQL dla libdbi
39 Group:          Libraries
40 Requires:       libdbi >= %{dbiver}
41 Provides:       libdbi-dbd = %{version}-%{release}
42 Obsoletes:      libdbi-dbd-mysql
43
44 %description mysql
45 This plugin provides connectivity to MySQL database servers through
46 the libdbi database independent abstraction layer. Switching a
47 program's plugin does not require recompilation or rewriting source
48 code.
49
50 %description mysql -l pl
51 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z serwerami MySQL poprzez
52 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
53 zmiany ¼róde³ programu.
54
55 %package pgsql
56 Summary:        PostgreSQL plugin for libdbi
57 Summary(pl):    Wtyczka PostgreSQL dla libdbi
58 Group:          Libraries
59 Requires:       libdbi >= %{dbiver}
60 Provides:       libdbi-dbd = %{version}-%{release}
61 Obsoletes:      libdbi-dbd-pgsql
62
63 %description pgsql
64 This plugin provides connectivity to PostgreSQL database servers
65 through the libdbi database independent abstraction layer. Switching a
66 program's plugin does not require recompilation or rewriting source
67 code.
68
69 %description pgsql -l pl
70 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z serwerami PostgreSQL poprzez
71 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
72 zmiany ¼róde³ programu.
73
74 %package sqlite
75 Summary:        SQLite plugin for libdbi
76 Summary(pl):    Wtyczka SQLite dla libdbi
77 Group:          Libraries
78 Requires:       libdbi >= %{dbiver}
79 Provides:       libdbi-dbd = %{version}-%{release}
80
81 %description sqlite
82 This plugin provides connectivity to SQLite engine
83 through the libdbi database independent abstraction layer. Switching a
84 program's plugin does not require recompilation or rewriting source
85 code.
86
87 %description sqlite -l pl
88 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z silnikiem SQLite poprzez
89 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
90 zmiany ¼róde³ programu.
91
92 %prep
93 %setup -q
94
95 %build
96 rm -f missing
97 %{__libtoolize}
98 %{__aclocal}
99 %{__automake}
100 %{__autoconf}
101 %configure \
102         %{?with_sqlite:--with-sqlite} \
103         %{?with_mysql:--with-mysql} \
104         %{?with_pgsql:--with-pgsql} \
105         --with-dbi-incdir=%{_includedir} 
106 %{__make}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_libdir}/dbd
111
112 %{__make} DESTDIR=$RPM_BUILD_ROOT install
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %if %{with mysql}
118 %files mysql
119 %defattr(644,root,root,755)
120 %doc drivers/mysql/*.pdf drivers/mysql/dbd_mysql
121 %attr(755,root,root) %{_libdir}/dbd/libmysql.so
122 %endif
123
124 %if %{with pgsql}
125 %files pgsql
126 %defattr(644,root,root,755)
127 %doc drivers/pgsql/*.pdf drivers/pgsql/dbd_pgsql
128 %attr(755,root,root) %{_libdir}/dbd/libpgsql.so
129 %endif
130
131 %if %{with sqlite}
132 %files sqlite
133 %defattr(644,root,root,755)
134 %doc drivers/sqlite/*.pdf drivers/sqlite/dbd_sqlite
135 %{_libdir}/dbd/libsqlite.so
136 %endif
This page took 0.050547 seconds and 2 git commands to generate.