]> git.pld-linux.org Git - SPECS.git/blob - libcthreads.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libcthreads.spec
1 # see m4/libcerror.m4
2 %define         libcerror_ver   20120425
3 Summary:        Library to support cross-platform C threads functions
4 Summary(pl.UTF-8):      Biblioteka wspierająca wieloplatformowe funkcje obsługi wątków w C
5 Name:           libcthreads
6 Version:        20180724
7 Release:        1
8 License:        LGPL v3+
9 Group:          Libraries
10 #Source0Download: https://github.com/libyal/libcthreads/releases
11 Source0:        https://github.com/libyal/libcthreads/releases/download/%{version}/%{name}-alpha-%{version}.tar.gz
12 # Source0-md5:  db38f7521fbfd20502de5befd23166c7
13 URL:            https://github.com/libyal/libcthreads/
14 BuildRequires:  autoconf >= 2.59
15 BuildRequires:  automake >= 1.6
16 BuildRequires:  gettext-tools >= 0.18.1
17 BuildRequires:  libcerror-devel >= %{libcerror_ver}
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig
20 Requires:       libcerror >= %{libcerror_ver}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 libcthreads is a library to support cross-platform C thread functions.
25
26 %description -l pl.UTF-8
27 libcthreads to biblioteka wspierająca wieloplatformowe funkcje obsługi
28 wątków w C.
29
30 %package devel
31 Summary:        Header files for libcthreads library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libcthreads
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       libcerror-devel >= %{libcerror_ver}
36
37 %description devel
38 Header files for libcthreads library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki libcthreads.
42
43 %package static
44 Summary:        Static libcthreads library
45 Summary(pl.UTF-8):      Statyczna biblioteka libcthreads
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static libcthreads library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka libcthreads.
54
55 %prep
56 %setup -q
57
58 %build
59 %{__gettextize}
60 %{__libtoolize}
61 %{__aclocal} -I m4
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         --with-libcerror
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 # obsoleted by pkg-config
76 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcthreads.la
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc AUTHORS ChangeLog README
87 %attr(755,root,root) %{_libdir}/libcthreads.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libcthreads.so.1
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libcthreads.so
93 %{_includedir}/libcthreads
94 %{_includedir}/libcthreads.h
95 %{_pkgconfigdir}/libcthreads.pc
96 %{_mandir}/man3/libcthreads.3*
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/libcthreads.a
This page took 3.747287 seconds and 3 git commands to generate.