]> git.pld-linux.org Git - SPECS.git/blob - libcsystem.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libcsystem.spec
1 # see m4/${libname}.m4 />= for required version of particular library
2 %define         libcerror_ver   20120425
3 %define         libclocale_ver  20120425
4 %define         libcnotify_ver  20120425
5 %define         libcstring_ver  20120425
6 %define         libuna_ver      20120425
7 Summary:        Library to support cross-platform C system functions
8 Summary(pl.UTF-8):      Biblioteka wspierająca wieloplatformowe funkcje systemowe w C
9 Name:           libcsystem
10 Version:        20150629
11 Release:        1
12 License:        LGPL v3+
13 Group:          Libraries
14 #Source0Download: https://github.com/libyal/libcsystem/releases
15 Source0:        https://github.com/libyal/libcsystem/releases/download/%{version}/%{name}-alpha-%{version}.tar.gz
16 # Source0-md5:  0a4c89767cb52d26110097f894d81a8d
17 Patch0:         %{name}-system-libs.patch
18 URL:            https://github.com/libyal/libcsystem/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1.6
21 BuildRequires:  gettext-tools >= 0.18.1
22 BuildRequires:  libcerror-devel >= %{libcerror_ver}
23 BuildRequires:  libclocale-devel >= %{libclocale_ver}
24 BuildRequires:  libcnotify-devel >= %{libcnotify_ver}
25 BuildRequires:  libcstring-devel >= %{libcstring_ver}
26 BuildRequires:  libuna-devel >= %{libuna_ver}
27 BuildRequires:  libtool
28 BuildRequires:  pkgconfig
29 Requires:       libcerror >= %{libcerror_ver}
30 Requires:       libclocale >= %{libclocale_ver}
31 Requires:       libcnotify >= %{libcnotify_ver}
32 Requires:       libcstring >= %{libcstring_ver}
33 Requires:       libuna >= %{libuna_ver}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 libcsystem is a library to support cross-platform C system functions.
38
39 %description -l pl.UTF-8
40 libcsystem to biblioteka wspierająca wieloplatformowe funkcje
41 systemowe w C.
42
43 %package devel
44 Summary:        Header files for libcsystem library
45 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libcsystem
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       libcerror-devel >= %{libcerror_ver}
49 Requires:       libclocale-devel >= %{libclocale_ver}
50 Requires:       libcnotify-devel >= %{libcnotify_ver}
51 Requires:       libcstring-devel >= %{libcstring_ver}
52 Requires:       libuna-devel >= %{libuna_ver}
53
54 %description devel
55 Header files for libcsystem library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki libcsystem.
59
60 %package static
61 Summary:        Static libcsystem library
62 Summary(pl.UTF-8):      Statyczna biblioteka libcsystem
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static libcsystem library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka libcsystem.
71
72 %prep
73 %setup -q
74 %patch0 -p1
75
76 %build
77 %{__gettextize}
78 %{__libtoolize}
79 %{__aclocal} -I m4
80 %{__autoconf}
81 %{__autoheader}
82 %{__automake}
83 %configure
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88
89 %{__make} install \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 # obsoleted by pkg-config
93 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcsystem.la
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc AUTHORS ChangeLog README
104 %attr(755,root,root) %{_libdir}/libcsystem.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libcsystem.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libcsystem.so
110 %{_includedir}/libcsystem
111 %{_includedir}/libcsystem.h
112 %{_pkgconfigdir}/libcsystem.pc
113 %{_mandir}/man3/libcsystem.3*
114
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libcsystem.a
This page took 3.557428 seconds and 3 git commands to generate.