]> git.pld-linux.org Git - packages/libcroco.git/blob - libcroco.spec
- new; added am patch to fix csslint includes and linking issues,
[packages/libcroco.git] / libcroco.spec
1 #
2 # Conditional build:
3 # _without_gnome        - without layout engine (which requires libgnomeui)
4 #
5 # NOTE: layeng could be separated, but pkg-config --libs libcroco returns
6 #       all built libraries together...
7 #
8 Summary:        A CSS2 parsing library
9 Summary(pl):    Biblioteka analizuj±ca CSS2
10 Name:           libcroco
11 Version:        0.3.0
12 Release:        1
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/gnome/sources/libcroco/0.3/%{name}-%{version}.tar.bz2
16 # Source0-md5:  f31718e45a22870b0ce655fe2edc6dd9
17 Patch0:         %{name}-am.patch
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  glib2-devel >= 2.0
21 %{!?_without_gnome:BuildRequires:       libgnomeui-devel >= 2.0.3}
22 BuildRequires:  libtool >= 1:1.4.2-9
23 BuildRequires:  libxml2-devel >= 2.4.23
24 BuildRequires:  pango-devel >= 1.0.4
25 BuildRequires:  pkgconfig >= 0.8
26 Requires:       glib2 >= 2.0
27 Requires:       libxml2 >= 2.4.23
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 CSS2 parsing and manipulation library for GNOME.
32
33 %description -l pl
34 Biblioteka analizuj±ca i obrabiaj±ca CSS2 dla GNOME.
35
36 %package devel
37 Summary:        Header files for developing with libcroco
38 Summary(pl):    Pliki nag³ówkowe do tworzenia programów u¿ywaj±cych libcroco
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}
41 Requires:       glib2-devel >= 2.0
42 Requires:       libxml2-devel >= 2.4.23
43
44 %description devel
45 This package provides the necessary header files files to allow you
46 to develop with libcroco.
47
48 %description devel -l pl
49 Ten pakiet dostarcza pliki nag³ówkowe potrzebne do tworzenia
50 oprogramowania korzystaj±cego z libcroco.
51
52 %package static
53 Summary:        Static version of libcroco library
54 Summary(pl):    Statyczna wersja biblioteki libcroco
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}
57
58 %description static
59 Static version of libcroco library.
60
61 %description static -l pl
62 Statyczna wersja biblioteki libcroco.
63
64 %prep
65 %setup -q
66 %patch -p1
67
68 %build
69 %{__libtoolize}
70 %{__aclocal}
71 %{__autoconf}
72 %{__autoheader}
73 %{__automake}
74 %configure \
75         --enable-seleng=yes \
76         --enable-layeng=%{?_without_gnome:no}%{!?_without_gnome:yes}
77
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
87 install docs/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS ChangeLog NEWS README TODO
98 %attr(755,root,root) %{_bindir}/csslint
99 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
100 %{_mandir}/man1/csslint.1*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc docs/usage.txt
105 %attr(755,root,root) %{_bindir}/croco-config
106 %attr(755,root,root) %{_libdir}/lib*.so
107 %{_libdir}/lib*.la
108 %{_includedir}/libcroco
109 %{_pkgconfigdir}/libcroco.pc
110 %{_mandir}/man1/croco-config.1*
111 %{_examplesdir}/%{name}-%{version}
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/lib*.a
This page took 0.061165 seconds and 4 git commands to generate.