]> git.pld-linux.org Git - packages/libcmis.git/blob - libcmis.spec
- release 2 (rebuild with boost 1.63)
[packages/libcmis.git] / libcmis.spec
1 #
2 # Conditonal build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A C++ client library for the CMIS interface
6 Summary(pl.UTF-8):     Biblioteka klienta C++ dla inferfejsu CMIS
7 Name:           libcmis
8 Version:        0.5.1
9 Release:        2
10 License:        GPL v2+ or LGPL v2+ or MPL v1.1
11 Group:          Libraries
12 #Source0Download: https://github.com/tdf/libcmis/releases
13 Source0:        https://github.com/tdf/libcmis/releases/download/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  3270154f0f40d86fce849b161f914101
15 #Source0:       http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
16 URL:            http://sourceforge.net/projects/libcmis/
17 BuildRequires:  autoconf >= 2.63
18 BuildRequires:  automake
19 BuildRequires:  boost-devel >= 1.36
20 BuildRequires:  cppunit-devel >= 1.12
21 BuildRequires:  curl-devel >= 7.12.3
22 BuildRequires:  docbook2X >= 0.8.8-4
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:2
25 BuildRequires:  libxml2-devel >= 2.0
26 BuildRequires:  pkgconfig
27 Requires:       curl-libs >= 7.12.3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 LibCMIS is a C++ client library for the CMIS interface. This allows
32 C++ applications to connect to any ECM behaving as a CMIS server like
33 Alfresco, Nuxeo for the open source ones.
34
35 %description -l pl.UTF-8
36 LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona 
37 aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
38 serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
39 o otwartych źródłach).
40
41 %package devel
42 Summary:        Development files for CMIS library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMIS
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       boost-devel >= 1.36
47 Requires:       curl-devel >= 7.12.3
48 Requires:       libstdc++-devel
49 Requires:       libxml2-devel >= 2.0
50
51 %description devel
52 This package contains the header files for developing applications
53 that use CMIS library.
54
55 %description devel -l pl.UTF-8
56 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
57 bibliotece CMIS
58
59 %package static
60 Summary:        Static CMIS library
61 Summary(pl.UTF-8):      Statyczna biblioteka CMIS
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static CMIS library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka CMIS.
70
71 %package tools
72 Summary:        Command line tool to access CMIS
73 Summary(pl.UTF-8):      Narzędzie wiersza poleceń dla CMIS
74 Group:          Applications/Publishing
75 Requires:       %{name} = %{version}-%{release}
76
77 %description tools
78 This package contains a tool for accessing CMIS from the command line.
79
80 %description tools -l pl.UTF-8
81 Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
82 poleceń.
83
84 %prep
85 %setup -q
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I m4
90 %{__autoconf}
91 %{__automake}
92 %configure \
93         DOCBOOK2MAN=/usr/bin/docbook2X2man \
94         --disable-silent-rules \
95         %{!?with_static_libs:--disable-static} \
96         --disable-tests \
97         --disable-werror
98
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 # obsoleted by pkg-config
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS ChangeLog NEWS
119 %attr(755,root,root) %{_libdir}/libcmis-0.5.so.*.*.*
120 %attr(755,root,root) %ghost %{_libdir}/libcmis-0.5.so.5
121 %attr(755,root,root) %{_libdir}/libcmis-c-0.5.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libcmis-c-0.5.so.5
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libcmis-0.5.so
127 %attr(755,root,root) %{_libdir}/libcmis-c-0.5.so
128 %{_includedir}/libcmis-0.5
129 %{_includedir}/libcmis-c-0.5
130 %{_pkgconfigdir}/libcmis-0.5.pc
131 %{_pkgconfigdir}/libcmis-c-0.5.pc
132
133 %if %{with static_libs}
134 %files static
135 %defattr(644,root,root,755)
136 %{_libdir}/libcmis-0.5.a
137 %{_libdir}/libcmis-c-0.5.a
138 %endif
139
140 %files tools
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/cmis-client
143 %{_mandir}/man1/cmis-client.1*
This page took 0.072447 seconds and 4 git commands to generate.