]> git.pld-linux.org Git - packages/libcmis.git/blob - libcmis.spec
Rebuild with boost 1.50
[packages/libcmis.git] / libcmis.spec
1 #
2 # Conditonal build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        A C++ client library for the CMIS interface
6 Summary(pl.UTF-8):     Biblioteka klienta C++ dla inferfejsu CMIS
7 Name:           libcmis
8 Version:        0.1.0
9 Release:        3
10 License:        GPL v2+ or LGPL v2+ or MPL v1.1
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
13 # Source0-md5:  4be634617054ada5b6d1886f63160f4f
14 URL:            http://sourceforge.net/projects/libcmis/
15 BuildRequires:  boost-devel
16 BuildRequires:  curl-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libxml2-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 LibCMIS is a C++ client library for the CMIS interface. This allows
23 C++ applications to connect to any ECM behaving as a CMIS server like
24 Alfresco, Nuxeo for the open source ones.
25
26 %description -l pl.UTF-8
27 LibCMIS to biblioteka klienta C++ dla interfejsu CMIS. Pozwala ona 
28 aplikacjom C++ na łączenie się z każdym ECM zachowującym się jako
29 serwer CMIS, taki jak Alfresco, Nuxeo (biorąc pod uwagę implementacje
30 o otwartych źródłach).
31
32 %package devel
33 Summary:        Development files for CMIS library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CMIS
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       boost-devel
38 Requires:       libstdc++-devel
39
40 %description devel
41 This package contains the header files for developing applications
42 that use CMIS library.
43
44 %description devel -l pl.UTF-8
45 Ten pakiet zawiera pliki nagłówkowe do tworzenia aplikacji opartych na
46 bibliotece CMIS
47
48 %package static
49 Summary:        Static CMIS library
50 Summary(pl.UTF-8):      Statyczna biblioteka CMIS
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static CMIS library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka CMIS.
59
60 %package tools
61 Summary:        Command line tool to access CMIS
62 Summary(pl.UTF-8):      Narzędzie wiersza poleceń dla CMIS
63 Group:          Applications/Publishing
64 Requires:       %{name} = %{version}-%{release}
65
66 %description tools
67 This package contains a tool for accessing CMIS from the command line.
68
69 %description tools -l pl.UTF-8
70 Ten pakiet zawiera narzędzie do łączenia się do CMIS z wiersza
71 poleceń.
72
73 %prep
74 %setup -q
75
76 %build
77 %configure \
78         %{!?with_static_libs:--disable-static} \
79         --disable-tests \
80         --disable-werror
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # obsoleted by pkg-config
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS ChangeLog README
102 %attr(755,root,root) %{_libdir}/%{name}-0.2.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libcmis-0.2.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/%{name}-0.2.so
108 %{_includedir}/%{name}
109 %{_pkgconfigdir}/%{name}-0.2.pc
110
111 %if %{with static_libs}
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libcmis-0.2.a
115 %endif
116
117 %files tools
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_bindir}/cmis-client
This page took 0.029248 seconds and 3 git commands to generate.