]> git.pld-linux.org Git - packages/libcmis.git/blob - libcmis.spec
1acbc5d2191c4832eb0a63465d5069c0a660ffdb
[packages/libcmis.git] / libcmis.spec
1 Summary:        A C++ client library for the CMIS interface
2 Name:           libcmis
3 Version:        0.1.0
4 Release:        1
5 License:        GPL+ or LGPLv2+ or MPLv1.1
6 Group:          Libraries
7 URL:            http://sourceforge.net/projects/libcmis/
8 Source0:        http://downloads.sourceforge.net/libcmis/%{name}-%{version}.tar.gz
9 # Source0-md5:  4be634617054ada5b6d1886f63160f4f
10 BuildRequires:  boost-devel
11 BuildRequires:  curl-devel
12 BuildRequires:  libxml2-devel
13
14 %description
15 LibCMIS is a C++ client library for the CMIS interface. This allows
16 C++ applications to connect to any ECM behaving as a CMIS server like
17 Alfresco, Nuxeo for the open source ones.
18
19 %package devel
20 Summary:        Development files for %{name}
21 Group:          Development/Libraries
22 Requires:       %{name} = %{version}-%{release}
23 Requires:       pkgconfig
24
25 %description devel
26 The %{name}-devel package contains libraries and header files for
27 developing applications that use %{name}.
28
29 %package tools
30 Summary:        Command line tool to access CMIS
31 Group:          Applications/Publishing
32 Requires:       %{name} = %{version}-%{release}
33
34 %description tools
35 The %{name}-tools package contains a tool for accessing CMIS from the
36 command line.
37
38 %prep
39 %setup -q
40
41 %build
42 %configure \
43         --disable-static \
44         --disable-tests \
45         --disable-werror
46
47 %{__make}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post -p /sbin/ldconfig
61 %postun -p /sbin/ldconfig
62
63 %files
64 %defattr(644,root,root,755)
65 %doc AUTHORS COPYING.* README
66 %attr(755,root,root) %{_libdir}/%{name}-0.2.so.*
67
68 %files devel
69 %defattr(644,root,root,755)
70 %{_includedir}/%{name}
71 %attr(755,root,root) %{_libdir}/%{name}-0.2.so
72 %{_pkgconfigdir}/%{name}-0.2.pc
73
74 %files tools
75 %defattr(644,root,root,755)
76 %attr(755,root,root) %{_bindir}/cmis-client
This page took 0.045264 seconds and 2 git commands to generate.