]> git.pld-linux.org Git - SPECS.git/blob - libclastfm.spec
SPECS updated Mon 29 Apr 22:05:02 CEST 2024
[SPECS.git] / libclastfm.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 Summary:        Unofficial C-API for the Last.fm web service
6 Summary(pl.UTF-8):      Nieoficjalne API C usługi WWW Last.fm
7 Name:           libclastfm
8 Version:        0.5
9 Release:        1
10 License:        GPL v3+
11 Group:          Libraries
12 Source0:        http://downloads.sourceforge.net/liblastfm/%{name}-%{version}.tar.gz
13 # Source0-md5:  0a71c485726a7e8970b970f520508a9b
14 URL:            http://liblastfm.sourceforge.net/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake
17 BuildRequires:  curl-devel
18 BuildRequires:  libtool >= 2:2
19 BuildRequires:  pkgconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 libclastfm is an unofficial C-API for the Last.fm web service written
24 with libcurl. It was written because the official CBS Interactive
25 Last.fm library requires Qt, which is usually not desired when using
26 GTK+ based distros.
27
28 This library supports much more than basic scrobble submission. You
29 can send shouts, fetch Album covers and much more.
30
31 Due to the naming conflict with the official last.fm library, this
32 library will install as "libclastfm".
33
34 %description -l pl.UTF-8
35 libclastfm to nieoficjalne API języka C do usługi WWW Last.fm,
36 napisane z użyciem biblioteki libcurl. Powstało, ponieważ oficjalna
37 biblioteka CBS Interactive Last.fm wymaga biblioteki Qt, która jest
38 zwykle niepożądana w przypadku korzystania z dystrybucji opartych na
39 GTK+.
40
41 Biblioteka ta obsługuje dużo więcej, niż proste wysyłanie swoich
42 preferencji (scrobble); można wysyłać okrzyki, pobierać okładki
43 albumów itp.
44
45 Ze względu na konflikt nazw z oficjalną biblioteką last.fm, ta jest
46 instalowana pod nazwą "libclastfm".
47
48 %package devel
49 Summary:        Development files for libclastfm
50 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libcflastfm
51 Group:          Development/Libraries
52 Requires:       %{name} = %{version}-%{release}
53 Requires:       curl-devel
54
55 %description devel
56 This package contains files for developing applications that use
57 libclastfm.
58
59 %description devel -l pl.UTF-8
60 Ten pakiet zawiera pliki do tworzenia aplikacji wykorzystujących
61 bibliotekę libclastfm.
62
63 %package static
64 Summary:        Static libclastfm library
65 Summary(pl.UTF-8):      Statyczna biblioteka libclastfm
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static libclastfm library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka libclastfm.
74
75 %prep
76 %setup -q
77
78 %build
79 %{__libtoolize}
80 %{__aclocal}
81 %{__autoconf}
82 %{__autoheader}
83 %{__automake}
84 %configure \
85         %{!?with_static_libs:--disable-static}
86
87 %{__make}
88
89 %install
90 rm -rf $RPM_BUILD_ROOT
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libclastfm.la
95
96 %clean
97 rm -rf $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc AUTHORS README
105 %attr(755,root,root) %{_libdir}/libclastfm.so.*.*.*
106 %attr(755,root,root) %ghost %{_libdir}/libclastfm.so.0
107
108 %files devel
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{_libdir}/libclastfm.so
111 %{_includedir}/clastfm.h
112 %{_pkgconfigdir}/libclastfm.pc
113
114 %if %{with static_libs}
115 %files static
116 %defattr(644,root,root,755)
117 %{_libdir}/libclastfm.a
118 %endif
This page took 0.434901 seconds and 3 git commands to generate.