]> git.pld-linux.org Git - packages/libcaca.git/blob - libcaca.spec
- 0.8
[packages/libcaca.git] / libcaca.spec
1 Summary:        Graphics library that outputs text instead of pixels
2 Summary(pl):    Biblioteka graficzna wy¶wietlaj±ca tekst zamiast pikseli
3 Name:           libcaca
4 Version:        0.8
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://sam.zoy.org/projects/libcaca/%{name}-%{version}.tar.bz2
9 # Source0-md5:  15c82b1b91b6e2c4c15f131cd31fa578
10 URL:            http://sam.zoy.org/projects/libcaca/
11 BuildRequires:  autoconf >= 2.50
12 BuildRequires:  automake
13 BuildRequires:  doxygen
14 BuildRequires:  imlib2-devel
15 BuildRequires:  libtool
16 BuildRequires:  slang-devel
17 # shouldn't these be in doxygen requirements?
18 BuildRequires:  tetex-fonts-jknappen
19 BuildRequires:  tetex-makeindex
20 BuildRequires:  XFree86-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         specflags       -fomit-frame-pointer
24
25 %description
26 The libcaca library is a graphics library that outputs text instead of
27 pixels, so that it can work on older video cards or text terminals. It
28 is not unlike the famous AAlib library.
29
30 The differences with AAlib are the following:
31 - 16 available colours for character output (256 colour pairs)
32 - dithering of colour images
33 - basic sprite primitives
34
35 But libcaca also has the following limitations:
36 - no support for brightness, contrast, gamma
37 - unefficient character-choosing algorithms
38 - no raw keyboard support
39
40 %description -l pl
41 Biblioteka libcaca to biblioteka graficzna wy¶wietlaj±ca tekst zamiast
42 pikseli, dziêki czemu mo¿e dzia³aæ na starszych kartach graficznych
43 oraz terminalach tekstowych. Pod tym wzglêdem jest podobna do s³ynnej
44 biblioteki AAlib.
45
46 Ró¿nice w stosunku do AAlib s± nastêpuj±ce:
47 - 16 dostêpnych kolorów dla znaków (256 par kolorów)
48 - dithering kolorowych obrazów
49 - proste kszta³ty duszków (sprites)
50
51 Ale libcaca ma tak¿e nastêpuj±ce ograniczenia:
52 - brak obs³ugi jasno¶ci, kontrakstu, korekcji gamma
53 - ma³o wydajne algorytmy wyboru znaków
54 - brak obs³ugi klawiatury w trybie surowym
55
56 %package devel
57 Summary:        Header files for libcaca library
58 Summary(pl):    Pliki nag³ówkowe biblioteki libcaca
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       slang-devel
62
63 %description devel
64 Header files for libcaca library.
65
66 %description devel -l pl
67 Pliki nag³ówkowe biblioteki libcaca.
68
69 %package static
70 Summary:        Static libcaca library
71 Summary(pl):    Statyczna biblioteka libcaca
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libcaca library.
77
78 %description static -l pl
79 Statyczna biblioteka libcaca.
80
81 %prep
82 %setup -q
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__autoheader}
89 %{__automake}
90 %configure \
91         --enable-x11 \
92         --disable-ncurses \
93         --enable-slang
94
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 # replace symlink by groff include
104 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/caca{ball,fire,moir,plas}.1
105 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaball.1
106 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacafire.1
107 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacamoir.1
108 echo '.so cacademo.1' > $RPM_BUILD_ROOT%{_mandir}/man1/cacaplas.1
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 #%post  -p /sbin/ldconfig
114 #%postun        -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS BUGS ChangeLog NEWS NOTES README TODO
119 %attr(755,root,root) %{_bindir}/cacaball
120 %attr(755,root,root) %{_bindir}/cacademo
121 %attr(755,root,root) %{_bindir}/cacafire
122 %attr(755,root,root) %{_bindir}/cacamoir
123 %attr(755,root,root) %{_bindir}/cacaplas
124 %attr(755,root,root) %{_bindir}/cacaview
125 #%attr(755,root,root) %{_libdir}/libcaca.so.*.*.*
126
127 %{_datadir}/%{name}
128 %{_mandir}/man1/cacaball.1*
129 %{_mandir}/man1/cacademo.1*
130 %{_mandir}/man1/cacafire.1*
131 %{_mandir}/man1/cacamoir.1*
132 %{_mandir}/man1/cacaplas.1*
133 %{_mandir}/man1/cacaview.1*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %doc doc/html/*
138 %attr(755,root,root) %{_bindir}/caca-config
139 #%attr(755,root,root) %{_libdir}/libcaca.so
140 #%{_libdir}/libcaca.la
141 %{_libdir}/libcaca.a
142 %{_libdir}/libcaca_pic.a
143 %{_includedir}/*.h
144 %{_mandir}/man1/caca-config.1*
145 # man3 pages have too common base names to be included
146
147 #%files static
148 #%defattr(644,root,root,755)
149 #%{_libdir}/libcaca.a
This page took 0.072399 seconds and 4 git commands to generate.