]> git.pld-linux.org Git - packages/libbsd.git/blob - libbsd.spec
7d7474a7b23a8fdd540056cb03ebe56e7127242b
[packages/libbsd.git] / libbsd.spec
1 # TODO
2 # - take french bitstring.3 from fcron?
3 # - conflict with libbsd.a from glibc no longer exist?
4 Summary:        Utility functions from BSD systems
5 Summary(pl.UTF-8):      Funkcje narzędziowe z systemów BSD
6 Name:           libbsd
7 Version:        0.7.0
8 Release:        2
9 License:        BSD, MIT (depending on part)
10 Group:          Libraries
11 Source0:        http://libbsd.freedesktop.org/releases/%{name}-%{version}.tar.xz
12 # Source0-md5:  fcceb4e66fd448ca4ed42ba22a8babb0
13 URL:            http://libbsd.freedesktop.org/
14 BuildRequires:  sed >= 4.0
15 BuildRequires:  tar >= 1:1.22
16 BuildRequires:  xz
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This library provides useful functions commonly found on BSD systems,
21 and lacking on others like GNU systems, thus making it easier to port
22 projects with strong BSD origins, without needing to embed the same
23 code over and over again on each project.
24
25 %description -l pl.UTF-8
26 Ta biblioteka udostępnia funkcje zwykle spotykane w systemach BSD, a
27 nie występujące na innych, takich jak systemy GNU. Dzięki temu ułatwia
28 portowanie projektów mających silne korzenie BSD bez potrzeby
29 osadzania ciągle tego samego kodu w każdym projekcie.
30
31 %package devel
32 Summary:        Header files for BSD library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki BSD
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for BSD library.
39
40 Note: to avoid clash with libbsd.a from glibc, library provided by
41 this package is available as -lbsdutil.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki BSD.
45
46 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
47 dostarczana przez ten pakiet jest dostępna jako -lbsdutil.
48
49 %package static
50 Summary:        Static BSD library
51 Summary(pl.UTF-8):      Statyczna biblioteka BSD
52 Group:          Development/Libraries
53 Requires:       %{name}-devel = %{version}-%{release}
54
55 %description static
56 Static BSD library.
57
58 Note: to avoid clash with libbsd.a from glibc, library provided by
59 this package is available as libbsdutil.a.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka BSD.
63
64 Uwaga: aby zapobiec konfliktowi z libbsd.a z glibc, biblioteka
65 dostarczana przez ten pakiet jest dostępna jako libbsdutil.a.
66
67 %prep
68 %setup -q
69
70 %build
71 %configure \
72         --disable-silent-rules
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # avoid clash with libbsd.a from glibc
82 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.so
83 mv $RPM_BUILD_ROOT%{_libdir}/{libbsd,libbsdutil}.a
84 sed -i -e 's/-lbsd/-lbsdutil/' $RPM_BUILD_ROOT%{_pkgconfigdir}/{libbsd,libbsd-overlay}.pc
85 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbsd.la
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc COPYING ChangeLog README TODO
96 %attr(755,root,root) %{_libdir}/libbsd.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libbsd.so.0
98
99 %files devel
100 %defattr(644,root,root,755)
101 %attr(755,root,root) %{_libdir}/libbsdutil.so
102 %{_libdir}/libbsd-ctor.a
103 %{_includedir}/bsd
104 %{_pkgconfigdir}/libbsd.pc
105 %{_pkgconfigdir}/libbsd-ctor.pc
106 %{_pkgconfigdir}/libbsd-overlay.pc
107 %{_mandir}/man3/arc4random*.3*
108 %{_mandir}/man3/bitstring.3*
109 %{_mandir}/man3/closefrom.3*
110 %{_mandir}/man3/dehumanize_number.3*
111 %{_mandir}/man3/expand_number.3*
112 %{_mandir}/man3/fgetln.3*
113 %{_mandir}/man3/fgetwln.3*
114 %{_mandir}/man3/flopen.3*
115 %{_mandir}/man3/fmtcheck.3*
116 %{_mandir}/man3/fparseln.3*
117 %{_mandir}/man3/funopen.3*
118 %{_mandir}/man3/getbsize.3*
119 %{_mandir}/man3/getmode.3*
120 %{_mandir}/man3/getpeereid.3*
121 %{_mandir}/man3/getprogname.3*
122 %{_mandir}/man3/heapsort.3*
123 %{_mandir}/man3/humanize_number.3*
124 %{_mandir}/man3/md5.3bsd*
125 %{_mandir}/man3/mergesort.3*
126 %{_mandir}/man3/nlist.3*
127 %{_mandir}/man3/pidfile.3*
128 %{_mandir}/man3/queue.3bsd*
129 %{_mandir}/man3/radixsort.3*
130 %{_mandir}/man3/readpassphrase.3*
131 %{_mandir}/man3/reallocf.3*
132 %{_mandir}/man3/setmode.3*
133 %{_mandir}/man3/setproctitle.3*
134 %{_mandir}/man3/setprogname.3*
135 %{_mandir}/man3/sradixsort.3*
136 %{_mandir}/man3/stringlist.3*
137 %{_mandir}/man3/strlcat.3*
138 %{_mandir}/man3/strlcpy.3*
139 %{_mandir}/man3/strmode.3*
140 %{_mandir}/man3/strnstr.3*
141 %{_mandir}/man3/strtonum.3*
142 %{_mandir}/man3/tree.3*
143 %{_mandir}/man3/unvis.3*
144 %{_mandir}/man3/vis.3*
145 %{_mandir}/man3/wcslcat.3*
146 %{_mandir}/man3/wcslcpy.3*
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/libbsdutil.a
This page took 0.093042 seconds and 3 git commands to generate.