]> git.pld-linux.org Git - packages/libbinio.git/blob - libbinio.spec
- s/bcond_without static/bcond_without static_libs/
[packages/libbinio.git] / libbinio.spec
1 %bcond_without  static_libs     # don't build static library
2 Summary:        Binary I/O stream class library
3 Summary(pl):    Biblioteka klas C++ dla strumieniowych binarnych operacji I/O
4 Name:           libbinio
5 Version:        1.3
6 Release:        0.1
7 License:        GPL/LGPL
8 Group:          Libraries
9 Source0:        http://dl.sourceforge.net/libbinio/%{name}-%{version}.tar.bz2
10 # Source0-md5:  dea7bd4c2d9d9f5429082448af2aab22
11 Patch0:         %{name}-infopage.patch
12 URL:            http://libbinio.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool >= 2:1.5
16 BuildRequires:  libstdc++-devel
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The binary I/O stream class library presents a platform-independent
21 way to access binary data streams in C++. The library is hardware
22 independent in the form that it transparently converts between the
23 different forms of machine-internal binary data representation. It
24 further employs no special I/O protocol and can be used on arbitrary
25 binary data sources.
26
27 %description -l pl
28 Biblioteka klas strumieniowych binarnych operacji wej¶cia/wyj¶cia
29 prezentuje niezale¿ny od platformy sposób dostêpu do binarnych
30 strumieni danych w C++. Biblioteka jest niezale¿na od sprzêtu dziêki
31 temu, ¿e w przezroczysty sposób wykonuje konwersjê pomiêdzy ró¿nymi
32 postaciami reprezentacji danych binarnych w wewnêtrznym formacie
33 maszyny. Co wiêcej, nie wykorzystuje ¿adnego specjalnego protoko³u
34 wej¶cia/wyj¶cia i mo¿e byæ u¿ywana na dowolnych ¼ród³ach danych
35 binarnych.
36
37 %package devel
38 Summary:        Header files for libbinio library
39 Summary(pl):    Pliki nag³ówkowe biblioteki libbinio
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42 Requires:       libstdc++-devel
43
44 %description devel
45 Header files for libbinio library.
46
47 %description devel -l pl
48 Pliki nag³ówkowe biblioteki libbinio.
49
50 %package static
51 Summary:        Static libbinio library
52 Summary(pl):    Statyczna biblioteka libbinio
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libbinio library.
58
59 %description static -l pl
60 Statyczna biblioteka libbinio.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__autoconf}
70 %{__automake}
71 %configure \
72         %{!?with_static_libs:--disable-static}
73 %{__make}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %post   -p /sbin/ldconfig
85 %postun -p /sbin/ldconfig
86
87 %post devel
88 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
89
90 %postun devel
91 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS ChangeLog NEWS README
96 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/lib*.so
101 %{_libdir}/lib*.la
102 %{_includedir}/*
103 %{_infodir}/*.info*
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/lib*.a
109 %endif
This page took 0.073485 seconds and 4 git commands to generate.