]> git.pld-linux.org Git - SPECS.git/blob - libafdt.spec
SPECS updated Wed 28 Jul 14:48:01 CEST 2021
[SPECS.git] / libafdt.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_without  tests           # skip tests
6
7 Summary:        LIBrary for Asynchronous File Descriptor Transfer
8 Name:           libafdt
9 Version:        0.1.0
10 Release:        6
11 License:        BSD
12 Group:          Libraries
13 Source0:        http://downloads.sourceforge.net/libafdt/%{name}-%{version}.tar.gz
14 # Source0-md5:  8051b4e88c5804ce34e221cb62c5e672
15 URL:            http://facebook.github.io/libafdt/
16 Patch0:         %{name}-link.patch
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_apidocs:BuildRequires:  doxygen}
20 BuildRequires:  libevent-devel >= 1.4.5
21 BuildRequires:  libtool
22 %{?with_tests:BuildRequires:    python}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 libafdt is a library for "a"synchronous "f"ile "d"escriptor
27 "t"ransfers. It provides a simple interface that allows libevent-based
28 programs to set up a Unix domain socket to accept connections and
29 transfer file descriptors to clients, or to be a client and request a
30 file descriptor from a libafdt server. Low-level and synchronous
31 interfaces are also provided for programs that do not use libevent.
32
33 %package devel
34 Summary:        Header files for libafdt library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libafdt
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for libafdt library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki libafdt.
44
45 %package static
46 Summary:        Static libafdt library
47 Summary(pl.UTF-8):      Statyczna biblioteka libafdt
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static libafdt library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka libafdt.
56
57 %package apidocs
58 Summary:        libafdt API documentation
59 Summary(pl.UTF-8):      Dokumentacja API biblioteki libafdt
60 Group:          Documentation
61 BuildArch:      noarch
62
63 %description apidocs
64 API and internal documentation for libafdt library.
65
66 %description apidocs -l pl.UTF-8
67 Dokumentacja API biblioteki libafdt.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal} -I m4
76 %{__autoconf}
77 %{__automake}
78 %configure \
79         --enable-shared \
80         %{!?with_static_libs:--disable-static}
81
82 %{__make}
83
84 %{?with_tests:%{__make} check}
85
86 %{?with_apidocs:doxygen}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README
102 %attr(755,root,root) %{_libdir}/libafdt.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libafdt.so.0
104
105 %files devel
106 %defattr(644,root,root,755)
107 %{_libdir}/libafdt.so
108 %{_libdir}/libafdt.la
109 %{_includedir}/afdt.h
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libafdt.a
114
115 %if %{with apidocs}
116 %files apidocs
117 %defattr(644,root,root,755)
118 %doc doxygen-out/html/*
119 %endif
This page took 0.825897 seconds and 3 git commands to generate.