]> git.pld-linux.org Git - packages/libabw.git/blob - libabw.spec
cc2985cd42d22635113d2f13177c2f4940991ff6
[packages/libabw.git] / libabw.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4
5 %define         apiversion      0.1
6 Summary:        A library for import of AbiWord files
7 Summary(pl.UTF-8):      Biblioteka do importowania plików AbiWorda
8 Name:           libabw
9 Version:        0.1.3
10 Release:        1
11 License:        MPL v2.0
12 Group:          Libraries
13 Source0:        https://dev-www.libreoffice.org/src/libabw/%{name}-%{version}.tar.xz
14 # Source0-md5:  0ec0331abbbf653f08eecceb1fb787a0
15 URL:            https://wiki.documentfoundation.org/DLP/Libraries/libabw
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf >= 3.0.0
19 BuildRequires:  librevenge-devel >= 0.0
20 BuildRequires:  libstdc++-devel >= 6:4.7
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libabw is a library for import of AbiWord files.
30
31 %description -l pl.UTF-8
32 libabw to biblioteka do importowania plików AbiWorda.
33
34 %package devel
35 Summary:        Development files for libabw
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libabw
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       librevenge-devel >= 0.0
40 Requires:       libstdc++-devel >= 6:4.7
41 Requires:       libxml2-devel >= 2.0
42 Requires:       zlib-devel
43
44 %description devel
45 This package contains the header files for developing applications
46 that use libabw.
47
48 %description devel -l pl.UTF-8
49 Ten pakiet zawiera biblioteki i pliki nagłówkowe do tworzenia
50 aplikacji wykorzystujących bibliotekę libabw.
51
52 %package static
53 Summary:        Static libabw library
54 Summary(pl.UTF-8):      Statyczna biblioteka libabw
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libabw library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libabw.
63
64 %package apidocs
65 Summary:        API documentation for libabw library
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki libabw
67 Group:          Documentation
68 %if "%{_rpmversion}" >= "5"
69 BuildArch:      noarch
70 %endif
71
72 %description apidocs
73 API documentation for libabw library.
74
75 %description apidocs -l pl.UTF-8
76 Dokumentacja API biblioteki libabw.
77
78 %package tools
79 Summary:        Tools to transform AbiWord files into other formats
80 Summary(pl.UTF-8):      Narzędzia do przekształcania plików AbiWorda do innych formatów
81 Group:          Applications/Publishing
82 Requires:       %{name} = %{version}-%{release}
83
84 %description tools
85 Tools to transform AbiWord files into other formats. Currently
86 supported: XHTML, raw, text.
87
88 %description tools -l pl.UTF-8
89 Narzędzia do przekształcania plików AbiWorda do innych formatów.
90 Obecnie obsługiwane są: XHTML, surowy, tekst.
91
92 %prep
93 %setup -q
94
95 %build
96 %configure \
97         --disable-silent-rules \
98         %{?with_static_libs:--enable-static}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
108
109 # we install API docs directly from build
110 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc CREDITS ChangeLog NEWS README
121 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so.*.*.*
122 %attr(755,root,root) %ghost %{_libdir}/libabw-%{apiversion}.so.1
123
124 %files devel
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so
127 %{_includedir}/libabw-%{apiversion}
128 %{_pkgconfigdir}/libabw-%{apiversion}.pc
129
130 %if %{with static_libs}
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/libabw-%{apiversion}.a
134 %endif
135
136 %files apidocs
137 %defattr(644,root,root,755)
138 %doc docs/doxygen/html/*
139
140 %files tools
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_bindir}/abw2raw
143 %attr(755,root,root) %{_bindir}/abw2text
144 %attr(755,root,root) %{_bindir}/abw2html
This page took 0.07786 seconds and 3 git commands to generate.