]> git.pld-linux.org Git - packages/libabw.git/blob - libabw.spec
- updated to 0.0.2
[packages/libabw.git] / libabw.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 %define         apiversion      0.0
6 Summary:        A library for import of AbiWord files
7 Summary(pl.UTF-8):      Biblioteka do importowania plików AbiWorda
8 Name:           libabw
9 Version:        0.0.2
10 Release:        1
11 License:        MPL v2.0
12 Group:          Libraries
13 Source0:        http://dev-www.libreoffice.org/src/%{name}-%{version}.tar.xz
14 # Source0-md5:  2d8c4255ae8ecd3fcc590fdecf7dc262
15 URL:            http://www.freedesktop.org/wiki/Software/libabw/
16 BuildRequires:  boost-devel
17 BuildRequires:  doxygen
18 BuildRequires:  gperf >= 3.0.0
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libwpd-devel >= 0.9
21 BuildRequires:  libxml2-devel >= 2.0
22 BuildRequires:  pkgconfig
23 BuildRequires:  tar >= 1:1.22
24 BuildRequires:  xz
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libabw is a library for import of AbiWord files.
30
31 %description -l pl.UTF-8
32 libabw to biblioteka do importowania plików AbiWorda.
33
34 %package devel
35 Summary:        Development files for libabw
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libabw
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       libstdc++-devel
40 Requires:       libwpd-devel >= 0.9
41
42 %description devel
43 This package contains the header files for developing applications
44 that use libabw.
45
46 %description devel -l pl.UTF-8
47 Ten pakiet zawiera biblioteki i pliki nagłówkowe do tworzenia
48 aplikacji wykorzystujących bibliotekę libabw.
49
50 %package static
51 Summary:        Static libabw library
52 Summary(pl.UTF-8):      Statyczna biblioteka libabw
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libabw library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka libabw.
61
62 %package apidocs
63 Summary:        API documentation for libabw library
64 Summary(pl.UTF-8):      Dokumentacja API biblioteki libabw
65 Group:          Documentation
66
67 %description apidocs
68 API documentation for libabw library.
69
70 %description apidocs -l pl.UTF-8
71 Dokumentacja API biblioteki libabw.
72
73 %package tools
74 Summary:        Tools to transform AbiWord files into other formats
75 Summary(pl.UTF-8):      Narzędzia do przekształcania plików AbiWorda do innych formatów
76 Group:          Applications/Publishing
77 Requires:       %{name} = %{version}-%{release}
78
79 %description tools
80 Tools to transform AbiWord files into other formats. Currently
81 supported: XHTML, raw, text.
82
83 %description tools -l pl.UTF-8
84 Narzędzia do przekształcania plików AbiWorda do innych formatów.
85 Obecnie obsługiwane są: XHTML, surowy, tekst.
86
87 %prep
88 %setup -q
89
90 %build
91 %configure \
92         --disable-silent-rules \
93         %{?with_static_libs:--enable-static} \
94         --disable-werror
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
104
105 # we install API docs directly from build
106 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc CREDITS ChangeLog NEWS README
117 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libabw-%{apiversion}.so.0
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libabw-%{apiversion}.so
123 %{_includedir}/libabw-%{apiversion}
124 %{_pkgconfigdir}/libabw-%{apiversion}.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libabw-%{apiversion}.a
130 %endif
131
132 %files apidocs
133 %defattr(644,root,root,755)
134 %doc docs/doxygen/html/*
135
136 %files tools
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_bindir}/abw2raw
139 %attr(755,root,root) %{_bindir}/abw2text
140 %attr(755,root,root) %{_bindir}/abw2html
This page took 0.142842 seconds and 3 git commands to generate.