]> git.pld-linux.org Git - packages/lib3ds.git/blob - lib3ds.spec
- added missing #
[packages/lib3ds.git] / lib3ds.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        The 3D Studio File Format Library
6 Summary(pl.UTF-8):      Biblioteka obsługująca format plików 3D Studio
7 Name:           lib3ds
8 Version:        1.2.0
9 Release:        2
10 License:        LGPL
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/lib3ds/%{name}-%{version}.tar.gz
13 # Source0-md5:  3a7f891d18af0151876b98bc05d3b373
14 Patch0:         %{name}-shared.patch
15 Patch1:         %{name}-am18.patch
16 URL:            http://lib3ds.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRequires:  sed >= 4.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 lib3ds is a free alternative to Autodesk's 3DS File Toolkit for
25 handling 3DS files. It's main goal is to simplify the creation of 3DS
26 import and export filters.
27
28 This project is not related in any form to Autodesk. The library is
29 based on unofficial information about the 3DS format found on the web.
30
31 %description -l pl.UTF-8
32 lib3ds to wolnodostępna alternatywa dla 3DS File Toolkit Autodeska do
33 obsługi plików 3DS. Głównym celem biblioteki jest uproszczenie
34 tworzenia filtrów importujących i eksportujących 3DS.
35
36 Projekt nie jest w żaden sposób związany z Autodeskiem. Biblioteka
37 jest oparta na nieoficjalnych informacjach o formacie 3DS znalezionych
38 w sieci.
39
40 %package devel
41 Summary:        lib3ds header files
42 Summary(pl.UTF-8):      Pliki nagłówkowe lib3ds
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 lib3ds header files.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe lib3ds.
51
52 %package static
53 Summary:        Static lib3ds library
54 Summary(pl.UTF-8):      Statyczna biblioteka lib3ds
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static lib3ds library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka lib3ds.
63
64 %prep
65 %setup -q
66 %patch0 -p1
67 %patch1 -p1
68
69 # extract CONFIGURE_GLUT macro
70 tail -n 116 aclocal.m4 | head -n 102 > acinclude.m4
71
72 %build
73 %{__libtoolize}
74 %{__aclocal}
75 %{__autoconf}
76 %{__autoheader}
77 %{__automake}
78 #CPPFLAGS="-I/usr/X11R6/include" - but GL/glut is used only for noinst_PROGRAMS
79 %configure \
80         %{!?with_static_libs:--disable-static}
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90 install examples/*.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
91 sed -i -e 's/@GLUT_HEADER_DIR@/GL/' examples/glstub.h.in \
92         $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/*
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc AUTHORS ChangeLog README
103 %attr(755,root,root) %{_bindir}/3ds*
104 %attr(755,root,root) %{_libdir}/lib3ds.so.*.*
105 %{_mandir}/man1/3ds*.1*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_bindir}/lib3ds-config
110 %attr(755,root,root) %{_libdir}/lib3ds.so
111 %{_libdir}/lib3ds.la
112 %{_includedir}/lib3ds
113 %{_aclocaldir}/*.m4
114 %{_mandir}/man1/lib3ds-config.1*
115 %{_examplesdir}/%{name}-%{version}
116
117 %if %{with static_libs}
118 %files static
119 %defattr(644,root,root,755)
120 %{_libdir}/lib3ds.a
121 %endif
This page took 0.075872 seconds and 3 git commands to generate.