]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
- static_libs bcond
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #Requires(postun):      -
19 #Requires(pre,post):    -
20 #Requires(preun):       -
21 #Requires:      -
22 #Provides:      -
23 #Obsoletes:     -
24 #Conflicts:     -
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28
29 #%description -l pl.UTF-8
30
31 %package devel
32 Summary:        Header files for FOO library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOO
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for FOO library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki FOO.
42
43 %package static
44 Summary:        Static FOO library
45 Summary(pl.UTF-8):      Statyczna biblioteka FOO
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static FOO library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka FOO.
54
55 %package apidocs
56 Summary:        FOO API documentation
57 Summary(pl.UTF-8):      Dokumentacja API biblioteki FOO
58 Group:          Documentation
59
60 %description apidocs
61 API and internal documentation for FOO library.
62
63 %description apidocs -l pl.UTF-8
64 Dokumentacja API biblioteki FOO.
65
66 %prep
67 %setup -q
68 #%patch0 -p1
69
70 %build
71 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
72 # appropriate BuildRequires
73 #%{__libtoolize}
74 #%{__aclocal}
75 #%{__autoconf}
76 #%{__autoheader}
77 #%{__automake}
78 %configure
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 # create directories if necessary
84 #install -d $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
98 %attr(755,root,root) %{_bindir}/*
99 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
100 %{_datadir}/%{name}
101
102 %files devel
103 %defattr(644,root,root,755)
104 %doc devel-doc/*
105 %{_libdir}/lib*.so
106 %{_libdir}/lib*.la
107 %{_includedir}/foo
108 %{_aclocaldir}/*.m4
109 %{_pkgconfigdir}/*.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.a
114
115 %files apidocs
116 %defattr(644,root,root,755)
117 %doc apidocs/*
This page took 0.043561 seconds and 4 git commands to generate.