]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
- added .la removal for pkgconfig enabled libs
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #Requires(postun):      -
19 #Requires(pre,post):    -
20 #Requires(preun):       -
21 #Requires:      -
22 #Provides:      -
23 #Obsoletes:     -
24 #Conflicts:     -
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # do not keep them in newly created specs
28 # these are only here to help fixing quickly broken specs
29 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
30 %define         filterout_ld    -Wl,--as-needed
31
32 # Ignore file in __spec_install_post_check_so
33 BuildRequires:    rpmbuild(macros) >= 1.583
34 %define         skip_post_check_so      libunresolved.so.*
35
36 %description
37
38 #%description -l pl.UTF-8
39
40 %package devel
41 Summary:        Header files for FOO library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOO
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for FOO library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki FOO.
51
52 %package static
53 Summary:        Static FOO library
54 Summary(pl.UTF-8):      Statyczna biblioteka FOO
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static FOO library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka FOO.
63
64 %package apidocs
65 Summary:        FOO API documentation
66 Summary(pl.UTF-8):      Dokumentacja API biblioteki FOO
67 Group:          Documentation
68
69 %description apidocs
70 API and internal documentation for FOO library.
71
72 %description apidocs -l pl.UTF-8
73 Dokumentacja API biblioteki FOO.
74
75 %prep
76 %setup -q
77 #%patch0 -p1
78
79 %build
80 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
81 # appropriate BuildRequires
82 #%{__libtoolize}
83 #%{__aclocal}
84 #%{__autoconf}
85 #%{__autoheader}
86 #%{__automake}
87 %configure \
88         %{!?with_static_libs:--disable-static}
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 # create directories if necessary
94 #install -d $RPM_BUILD_ROOT
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 # if library provides pkgconfig then remove .la pollution
100 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
111 %attr(755,root,root) %{_bindir}/*
112 %attr(755,root,root) %{_libdir}/libFOO.so.*.*.*
113 %attr(755,root,root) %ghost %{_libdir}/libFOO.so.[0-9]
114 %{_datadir}/%{name}
115
116 %files devel
117 %defattr(644,root,root,755)
118 %doc devel-doc/*
119 %{_libdir}/libFOO.so
120 %{_libdir}/libFOO.la
121 %{_includedir}/foo
122 %{_aclocaldir}/FOO.m4
123 %{_pkgconfigdir}/FOO.pc
124
125 %if %{with static_libs}
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libFOO.a
129 %endif
130
131 %if %{with apidocs}
132 %files apidocs
133 %defattr(644,root,root,755)
134 %doc apidocs/*
135 %endif
This page took 0.033291 seconds and 4 git commands to generate.