]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
- replaced FOO with %{name} which (or lib%{name}) is usually correct,
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #Requires(postun):      -
19 #Requires(pre,post):    -
20 #Requires(preun):       -
21 #Requires:      -
22 #Provides:      -
23 #Obsoletes:     -
24 #Conflicts:     -
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # do not keep them in newly created specs
28 # these are only here to help fixing quickly broken specs
29 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
30 %define         filterout_ld    -Wl,--as-needed
31
32 # Ignore file in __spec_install_post_check_so
33 BuildRequires:    rpmbuild(macros) >= 1.583
34 %define         skip_post_check_so      libunresolved.so.*
35
36 %description
37
38 #%description -l pl.UTF-8
39
40 %package common
41 Summary:        Common files for %{name} library
42 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
43 Group:          Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description common
47 Common files for %{name} library.
48
49 %description common -l pl.UTF-8
50 Wspólne pliki biblioteki %{name}.
51
52 %package devel
53 Summary:        Header files for %{name} library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for %{name} library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki %{name}.
63
64 %package static
65 Summary:        Static %{name} library
66 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static %{name} library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka %{name}.
75
76 %package apidocs
77 Summary:        %{name} API documentation
78 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
79 Group:          Documentation
80
81 %description apidocs
82 API and internal documentation for %{name} library.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki %{name}.
86
87 %prep
88 %setup -q
89 #%patch0 -p1
90
91 %build
92 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
93 # appropriate BuildRequires
94 #%{__libtoolize}
95 #%{__aclocal}
96 #%{__autoconf}
97 #%{__autoheader}
98 #%{__automake}
99 %configure \
100         %{!?with_static_libs:--disable-static}
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 # create directories if necessary
106 #install -d $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 # if library provides pkgconfig file containing proper {Requires,Libs}.private
112 # then remove .la pollution
113 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS CREDITS README THANKS
124 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
125 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
126
127 %files common
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/%{name}*
130 %{_datadir}/%{name}
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc devel-doc/* ChangeLog NEWS TODO
135 %attr(755,root,root) %{_libdir}/%{name}.so
136 # if no pkgconfig support, or it misses .private deps, then include .la file
137 #%{_libdir}/libFOO.la
138 %{_includedir}/%{name}
139 %{_aclocaldir}/%{name}.m4
140 %{_pkgconfigdir}/%{name}.pc
141
142 %if %{with static_libs}
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/%{name}.a
146 %endif
147
148 %if %{with apidocs}
149 %files apidocs
150 %defattr(644,root,root,755)
151 %doc apidocs/*
152 %endif
This page took 0.036839 seconds and 4 git commands to generate.