]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
- more ld macro samples
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #Requires(postun):      -
19 #Requires(pre,post):    -
20 #Requires(preun):       -
21 #Requires:      -
22 #Provides:      -
23 #Obsoletes:     -
24 #Conflicts:     -
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 # do not keep them in newly created specs
28 # these are only here to help fixing quickly broken specs
29 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
30 %define         filterout_ld    -Wl,--as-needed
31
32 # Ignore file in __spec_install_post_check_so
33 BuildRequires:    rpmbuild(macros) >= 1.583
34 %define         skip_post_check_so      libunresolved.so.*
35
36
37 %description
38
39 #%description -l pl.UTF-8
40
41 %package devel
42 Summary:        Header files for FOO library
43 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOO
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for FOO library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki FOO.
52
53 %package static
54 Summary:        Static FOO library
55 Summary(pl.UTF-8):      Statyczna biblioteka FOO
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static FOO library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka FOO.
64
65 %package apidocs
66 Summary:        FOO API documentation
67 Summary(pl.UTF-8):      Dokumentacja API biblioteki FOO
68 Group:          Documentation
69
70 %description apidocs
71 API and internal documentation for FOO library.
72
73 %description apidocs -l pl.UTF-8
74 Dokumentacja API biblioteki FOO.
75
76 %prep
77 %setup -q
78 #%patch0 -p1
79
80 %build
81 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
82 # appropriate BuildRequires
83 #%{__libtoolize}
84 #%{__aclocal}
85 #%{__autoconf}
86 #%{__autoheader}
87 #%{__automake}
88 %configure \
89         %{!?with_static_libs:--disable-static}
90 %{__make}
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94 # create directories if necessary
95 #install -d $RPM_BUILD_ROOT
96
97 %{__make} install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
109 %attr(755,root,root) %{_bindir}/*
110 %attr(755,root,root) %{_libdir}/libFOO.so.*.*.*
111 %{_datadir}/%{name}
112
113 %files devel
114 %defattr(644,root,root,755)
115 %doc devel-doc/*
116 %{_libdir}/libFOO.so
117 %{_libdir}/libFOO.la
118 %{_includedir}/foo
119 %{_aclocaldir}/FOO.m4
120 %{_pkgconfigdir}/FOO.pc
121
122 %if %{with static_libs}
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libFOO.a
126 %endif
127
128 %if %{with apidocs}
129 %files apidocs
130 %defattr(644,root,root,755)
131 %doc apidocs/*
132 %endif
This page took 0.04473 seconds and 4 git commands to generate.