]> git.pld-linux.org Git - projects/template-specs.git/blob - lib.spec
dokuwiki: drop non-common usecases
[projects/template-specs.git] / lib.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        -
7 Summary(pl.UTF-8):      -
8 Name:           ---
9 Version:        0.1
10 Release:        0.1
11 License:        - (enter GPL/LGPL/BSD/BSD-like/other license name here)
12 Group:          Libraries
13 Source0:        %{name}-%{version}.tar.gz
14 # Source0-md5:  -
15 #Patch0:        %{name}-what.patch
16 #URL:           -
17 #BuildRequires: -
18 #BuildRequires: autoconf
19 #BuildRequires: automake
20 #BuildRequires: intltool
21 #BuildRequires: libtool
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Obsoletes:     -
28 #Conflicts:     -
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # do not keep them in newly created specs
32 # these are only here to help fixing quickly broken specs
33 %define         filterout_ld    -Wl,--no-copy-dt-needed-entries
34 %define         filterout_ld    -Wl,--as-needed
35 # do not commit spec containing this (use for local testing only):
36 %define         filterout_c     -Werror=format-security
37 %define         filterout_cxx   -Werror=format-security
38
39 # Ignore file in __spec_install_post_check_so
40 BuildRequires:  rpmbuild(macros) >= 1.583
41 %define         skip_post_check_so      libunresolved.so.*
42
43 # do not commit spec containing this (use for local testing only):
44 %define         no_install_post_check_tmpfiles  1
45
46 %description
47
48 #%description -l pl.UTF-8
49
50 %package common
51 Summary:        Common files for %{name} library
52 Summary(pl.UTF-8):      Wspólne pliki biblioteki %{name}
53 Group:          Libraries
54 Requires:       %{name} = %{version}-%{release}
55
56 %description common
57 Common files for %{name} library.
58
59 %description common -l pl.UTF-8
60 Wspólne pliki biblioteki %{name}.
61
62 %package devel
63 Summary:        Header files for %{name} library
64 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description devel
69 Header files for %{name} library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki %{name}.
73
74 %package static
75 Summary:        Static %{name} library
76 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static %{name} library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka %{name}.
85
86 %package apidocs
87 Summary:        %{name} API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
89 Group:          Documentation
90
91 %description apidocs
92 API documentation for %{name} library.
93
94 %description apidocs -l pl.UTF-8
95 Dokumentacja API biblioteki %{name}.
96
97 %prep
98 %setup -q
99 #%patch0 -p1
100
101 %build
102 # if ac/am/lt/* rebuilding is necessary, do it in this order and add
103 # appropriate BuildRequires
104 #%{__libtoolize}
105 #%{__aclocal}
106 #%{__autoconf}
107 #%{__autoheader}
108 #%{__automake}
109 %configure \
110         %{!?with_static_libs:--disable-static}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 # create directories if necessary
116 #install -d $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 # if library provides pkgconfig file containing proper {Requires,Libs}.private
122 # then remove .la pollution
123 #%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %post   -p /sbin/ldconfig
129 %postun -p /sbin/ldconfig
130
131 %files
132 %defattr(644,root,root,755)
133 %doc AUTHORS CREDITS README THANKS
134 %attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/%{name}.so.N
136
137 %files common
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/%{name}*
140 %{_datadir}/%{name}
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc devel-doc/* ChangeLog NEWS TODO
145 %attr(755,root,root) %{_libdir}/%{name}.so
146 # if no pkgconfig support, or it misses .private deps, then include .la file
147 #%{_libdir}/libFOO.la
148 %{_includedir}/%{name}
149 %{_aclocaldir}/%{name}.m4
150 %{_pkgconfigdir}/%{name}.pc
151
152 %if %{with static_libs}
153 %files static
154 %defattr(644,root,root,755)
155 %{_libdir}/%{name}.a
156 %endif
157
158 %if %{with apidocs}
159 %files apidocs
160 %defattr(644,root,root,755)
161 %doc apidocs/*
162 %endif
This page took 0.037778 seconds and 3 git commands to generate.