]> git.pld-linux.org Git - packages/certbot.git/blob - letsencrypt.spec
use subver/rel macro; cleanups
[packages/certbot.git] / letsencrypt.spec
1 # TODO: finish, test
2 #
3 # Conditional build:
4 %bcond_without  doc             # don't build doc
5 %bcond_without  tests   # do not perform "make test"
6
7 %define         rel     1
8 %define         subver  20151017
9 Summary:        Let's Encrypt client
10 Name:           letsencrypt
11 Version:        0.0.0
12 Release:        0.%{subver}.%{rel}
13 License:        APL 2.0
14 Group:          Applications/Networking
15 Source0:        https://github.com/letsencrypt/letsencrypt/archive/v%{version}.dev%{subver}.tar.gz
16 # Source0-md5:  1cac8a454e466136f70834c76977ef17
17 URL:            https://letsencrypt.org/
18 BuildRequires:  python-modules
19 BuildRequires:  python-setuptools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.612
22 %if %{with tests}
23 BuildRequires:  python-mock
24 BuildRequires:  python-pythondialog
25 BuildRequires:  python-zope.component
26 BuildRequires:  python-zope.interface
27 %endif
28 %if %{with doc}
29 BuildRequires:  python-repoze.sphinx.autointerfac
30 BuildRequires:  sphinx-pdg
31 %endif
32 Requires:       python-cryptography
33 Requires:       python-modules
34 Requires:       python-pyOpenSSL
35 Requires:       python-pytz
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 The Let's Encrypt Client is a tool to automatically receive and
41 install X.509 certificates to enable TLS on servers. The client will
42 interoperate with the Let's Encrypt CA which will be issuing
43 browser-trusted certificates for free.
44
45 %prep
46 %setup -q -n %{name}-%{version}.dev%{subver}
47
48 %build
49 %{__python} setup.py build %{?with_tests:test}
50
51 %if %{with doc}
52 cd docs
53 %{__make} -j1 html
54 rm -r _build/html/_sources
55 %endif
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__python} setup.py \
60         build \
61         install --skip-build \
62         --optimize=2 \
63         --root=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc {CHANGES,README}.rst CONTRIBUTING.md %{?with_doc:docs/_build/html/*}
71 %attr(755,root,root) %{_bindir}/letsencrypt
72 %attr(755,root,root) %{_bindir}/letsencrypt-renewer
73 %{py_sitescriptdir}/letsencrypt
74 %{py_sitescriptdir}/letsencrypt-%{version}*-py*.egg-info
This page took 0.085215 seconds and 3 git commands to generate.