]> git.pld-linux.org Git - packages/dehydrated.git/blob - letsencrypt.sh.spec
add config.sh
[packages/dehydrated.git] / letsencrypt.sh.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           letsencrypt.sh
3 Version:        0.1.0
4 Release:        0.3
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  eadd134cc5365753c03929dd70db341d
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        config.sh
12 URL:            https://github.com/lukas2511/letsencrypt.sh
13 BuildRequires:  rpmbuild(macros) >= 1.713
14 Requires:       curl
15 Requires:       grep
16 Requires:       mktemp
17 Requires:       openssl
18 Requires:       sed
19 Requires:       webapps
20 Requires:       webserver(access)
21 Requires:       webserver(alias)
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _webapps        /etc/webapps
26 %define         _webapp         %{name}
27 %define         _sysconfdir     %{_webapps}/%{_webapp}
28 %define         _appdir         %{_datadir}/%{_webapp}
29
30 %description
31 This is a client for signing certificates with an ACME-server
32 (currently only provided by letsencrypt) implemented as a relatively
33 simple bash-script.
34
35 Current features:
36 - Signing of a list of domains
37 - Signing of a CSR
38 - Renewal if a certificate is about to expire or SAN (subdomains)
39   changed
40 - Certificate revocation
41
42 %prep
43 %setup -q
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/acme-challenges}
48
49 install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
50
51 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
52 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
53 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
54 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %triggerin -- apache1 < 1.3.37-3, apache1-base
60 %webapp_register apache %{_webapp}
61
62 %triggerun -- apache1 < 1.3.37-3, apache1-base
63 %webapp_unregister apache %{_webapp}
64
65 %triggerin -- apache < 2.2.0, apache-base
66 %webapp_register httpd %{_webapp}
67
68 %triggerun -- apache < 2.2.0, apache-base
69 %webapp_unregister httpd %{_webapp}
70
71 %triggerin -- lighttpd
72 %webapp_register lighttpd %{_webapp}
73
74 %triggerun -- lighttpd
75 %webapp_unregister lighttpd %{_webapp}
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.md CHANGELOG LICENSE
80 %dir %attr(750,root,http) %{_sysconfdir}
81 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
82 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
83 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
84 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
85 # challenges written here from letsencrypt.sh, need to be readable by webserver
86 %dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
87
88 %attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.028757 seconds and 3 git commands to generate.