]> git.pld-linux.org Git - SPECS.git/blob - ldns.spec
SPECS updated Tue 30 Apr 15:06:09 CEST 2024
[SPECS.git] / ldns.spec
1 # NOTE: included perl-DNS-LDNS module (--with-p5-dns-ldns) is older than in separate spec (0.61 vs 0.63)
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # static library
5 %bcond_without  python          # Python modules
6 #
7 Summary:        ldns - a library with the aim to simplify DNS programing in C
8 Summary(pl.UTF-8):      ldns - biblioteka mająca na celu uproszczenie programowania DNS w C
9 Name:           ldns
10 Version:        1.8.3
11 Release:        1
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
15 # Source0-md5:  429b93dacb2d6ecc5ed63788b14c38e6
16 Patch0:         python-install.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.nlnetlabs.nl/ldns/
19 BuildRequires:  autoconf >= 2.56
20 BuildRequires:  automake
21 BuildRequires:  doxygen
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  openssl-devel >= 1.1.0
24 %if %{with python}
25 BuildRequires:  python-devel >= 1:2.4.0
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 BuildRequires:  swig-python >= 2.0.4
29 %endif
30 Requires:       openssl >= 1.0.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 ldns is a library with the aim to simplify DNS programing in C. It is
35 heavily based upon the Net::DNS module from perl.
36
37 %description -l pl.UTF-8
38 ldns jest biblioteka mającą na celu uproszczenie programowania
39 związanego z usługą DNS w C. Jest w dużym stopniu oparta na module
40 Perla Net::DNS.
41
42 %package devel
43 Summary:        Header files for ldns library
44 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki ldns
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       openssl-devel >= 1.1.0
48
49 %description devel
50 Header files for ldns library.
51
52 %description devel -l pl.UTF-8
53 Pliki nagłówkowe biblioteki ldns.
54
55 %package static
56 Summary:        Static ldns library
57 Summary(pl.UTF-8):      Statyczna biblioteka ldns
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}-%{release}
60
61 %description static
62 Static ldns library.
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka ldns.
66
67 %package -n python-ldns
68 Summary:        Python interface do ldns library
69 Summary(pl.UTF-8):      Pythonowy interfejs do biblioteki ldns
70 Group:          Libraries/Python
71 Requires:       %{name} = %{version}-%{release}
72
73 %description -n python-ldns
74 Python interface do ldns library.
75
76 %description -n python-ldns -l pl.UTF-8
77 Pythonowy interfejs do biblioteki ldns.
78
79 %package -n drill
80 Summary:        drill - tool to get all sorts of information out of the DNS(SEC)
81 Summary(pl.UTF-8):      drill - narzędzie do pobierania dowolnych informacji z DNS(SEC)
82 Group:          Applications/Network
83 Requires:       %{name} = %{version}-%{release}
84
85 %description -n drill
86 drill is a tool to get all sorts of information out of the DNS. It is
87 specifically designed to be used with DNSSEC.
88
89 %description -n drill -l pl.UTF-8
90 drill to narzędzie do pobierania dowolnych informacji z DNS. Jest
91 zaprojektowane szczególnie z myślą o użyciu z DNSSEC.
92
93 %package tools
94 Summary:        Example tools for ldns
95 Summary(pl.UTF-8):      Przykładowe narzędzie wykorzystujące ldns
96 Group:          Applications/Network
97 Requires:       %{name} = %{version}-%{release}
98
99 %description tools
100 These tools are examples of ldns usage. They are not meant for
101 production systems and will not be supported as such.
102
103 %description tools -l pl.UTF-8
104 Te narzędzia są przykładami użycia biblioteki ldns.
105 Nie są przeznaczone do produkcyjnego użycia i jako takie
106 nie będa wspierane.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal}
116 %{__autoconf}
117 %{__autoheader}
118 %configure \
119         --with-examples \
120         --enable-gost-anyway \
121         --enable-static%{!?with_static_libs:=no} \
122         --with-drill \
123         %{?with_python:--with-pyldns}
124 %{__make}
125 %{__make} doc
126
127 # change symlinks into .so redirects
128 cd doc/man/man3
129 for f in `find . -type l`; do
130         d=`readlink $f`
131         %{__rm} $f
132         echo ".so $d" > $f
133 done
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 # obsoleted by pkg-config
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libldns.la
143
144 %if %{with python}
145 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.la
146 %if %{with static_libs}
147 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_ldns.a
148 %endif
149 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
150 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
151 %py_postclean
152 %endif
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post   -p /sbin/ldconfig
158 %postun -p /sbin/ldconfig
159
160 %files
161 %defattr(644,root,root,755)
162 %doc Changelog LICENSE README
163 %attr(755,root,root) %{_libdir}/libldns.so.*.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libldns.so.3
165
166 %files devel
167 %defattr(644,root,root,755)
168 %doc doc/{*.html,dns-lib-implementations,function_manpages,ldns_manpages,CodingStyle}
169 %attr(755,root,root) %{_bindir}/ldns-config
170 %attr(755,root,root) %{_libdir}/libldns.so
171 %{_pkgconfigdir}/ldns.pc
172 %{_includedir}/%{name}
173 %{_mandir}/man1/ldns-config.1*
174 %{_mandir}/man3/ldns_*.3*
175
176 %if %{with static_libs}
177 %files static
178 %defattr(644,root,root,755)
179 %{_libdir}/libldns.a
180 %endif
181
182 %if %{with python}
183 %files -n python-ldns
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{py_sitedir}/_ldns.so*
186 %{py_sitedir}/ldns.py[co]
187 %{py_sitedir}/ldnsx.py[co]
188 %endif
189
190 %files -n drill
191 %defattr(644,root,root,755)
192 %attr(755,root,root) %{_bindir}/drill
193 %{_mandir}/man1/drill.1*
194
195 %files tools
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/ldns-chaos
198 %attr(755,root,root) %{_bindir}/ldns-compare-zones
199 %attr(755,root,root) %{_bindir}/ldns-dane
200 %attr(755,root,root) %{_bindir}/ldns-dpa
201 %attr(755,root,root) %{_bindir}/ldns-gen-zone
202 %attr(755,root,root) %{_bindir}/ldns-key2ds
203 %attr(755,root,root) %{_bindir}/ldns-keyfetcher
204 %attr(755,root,root) %{_bindir}/ldns-keygen
205 %attr(755,root,root) %{_bindir}/ldns-mx
206 %attr(755,root,root) %{_bindir}/ldns-notify
207 %attr(755,root,root) %{_bindir}/ldns-nsec3-hash
208 %attr(755,root,root) %{_bindir}/ldns-read-zone
209 %attr(755,root,root) %{_bindir}/ldns-resolver
210 %attr(755,root,root) %{_bindir}/ldns-revoke
211 %attr(755,root,root) %{_bindir}/ldns-rrsig
212 %attr(755,root,root) %{_bindir}/ldns-signzone
213 %attr(755,root,root) %{_bindir}/ldns-test-edns
214 %attr(755,root,root) %{_bindir}/ldns-testns
215 %attr(755,root,root) %{_bindir}/ldns-update
216 %attr(755,root,root) %{_bindir}/ldns-verify-zone
217 %attr(755,root,root) %{_bindir}/ldns-version
218 %attr(755,root,root) %{_bindir}/ldns-walk
219 %attr(755,root,root) %{_bindir}/ldns-zcat
220 %attr(755,root,root) %{_bindir}/ldns-zsplit
221 %attr(755,root,root) %{_bindir}/ldnsd
222 %{_mandir}/man1/ldns-chaos.1*
223 %{_mandir}/man1/ldns-compare-zones.1*
224 %{_mandir}/man1/ldns-dane.1*
225 %{_mandir}/man1/ldns-dpa.1*
226 %{_mandir}/man1/ldns-gen-zone.1*
227 %{_mandir}/man1/ldns-key2ds.1*
228 %{_mandir}/man1/ldns-keyfetcher.1*
229 %{_mandir}/man1/ldns-keygen.1*
230 %{_mandir}/man1/ldns-mx.1*
231 %{_mandir}/man1/ldns-notify.1*
232 %{_mandir}/man1/ldns-nsec3-hash.1*
233 %{_mandir}/man1/ldns-read-zone.1*
234 %{_mandir}/man1/ldns-resolver.1*
235 %{_mandir}/man1/ldns-revoke.1*
236 %{_mandir}/man1/ldns-rrsig.1*
237 %{_mandir}/man1/ldns-signzone.1*
238 %{_mandir}/man1/ldns-test-edns.1*
239 %{_mandir}/man1/ldns-testns.1*
240 %{_mandir}/man1/ldns-update.1*
241 %{_mandir}/man1/ldns-verify-zone.1*
242 %{_mandir}/man1/ldns-version.1*
243 %{_mandir}/man1/ldns-walk.1*
244 %{_mandir}/man1/ldns-zcat.1*
245 %{_mandir}/man1/ldns-zsplit.1*
246 %{_mandir}/man1/ldnsd.1*
This page took 0.344773 seconds and 3 git commands to generate.