]> git.pld-linux.org Git - packages/ldb.git/blob - ldb.spec
- updated to 1.1.21
[packages/ldb.git] / ldb.spec
1 # TODO
2 # - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
3 %define         talloc_version  2:2.1.3
4 %define         tdb_version     2:1.3.7
5 %define         tevent_version  0.9.25
6 Summary:        LDAP-like embedded database
7 Summary(pl.UTF-8):      Wbudowana baza danych podobna do LDAP
8 Name:           ldb
9 Version:        1.1.21
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        https://www.samba.org/ftp/ldb/%{name}-%{version}.tar.gz
14 # Source0-md5:  94ba09c7452fff68df3481686c56677e
15 URL:            https://ldb.samba.org/
16 BuildRequires:  autoconf
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  libxslt
19 BuildRequires:  popt-devel >= 1.6
20 BuildRequires:  python-devel >= 1:2.4.2
21 BuildRequires:  python-talloc-devel >= %{talloc_version}
22 BuildRequires:  python-tdb >= %{tdb_version}
23 BuildRequires:  python-tevent >= %{tevent_version}
24 BuildRequires:  talloc-devel >= %{talloc_version}
25 BuildRequires:  tdb-devel >= %{tdb_version}
26 BuildRequires:  tevent-devel >= %{tevent_version}
27 Requires:       talloc >= %{talloc_version}
28 Requires:       tdb >= %{tdb_version}
29 Requires:       tevent >= %{tevent_version}
30 Requires:       popt >= 1.6
31 Provides:       libldb = %{version}-%{release}
32 Obsoletes:      libldb < 1.1.0-3
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 An extensible library that implements an LDAP like API to access
37 remote LDAP servers, or use local tdb databases.
38
39 %description -l pl.UTF-8
40 Rozszerzalna biblioteka implementująca API podobne do LDAP pozwalające
41 na dostęp do zdalnych serwerów LDAP lub wykorzystanie lokalnych baz
42 danych tdb.
43
44 %package tools
45 Summary:        Tools to manage LDB files
46 Summary(pl.UTF-8):      Narzędzia do zarządzania plikami LDB
47 Group:          Applications/Databases
48 Requires:       %{name} = %{version}-%{release}
49
50 %description tools
51 Tools to manage LDB files.
52
53 %description tools -l pl.UTF-8
54 Narzędzia do zarządzania plikami LDB.
55
56 %package devel
57 Summary:        Header files for the LDB library
58 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LDB
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       talloc-devel >= %{talloc_version}
62 Requires:       tdb-devel >= %{tdb_version}
63 Requires:       tevent-devel >= %{tevent_version}
64 Provides:       libldb-devel = %{version}-%{release}
65 Obsoletes:      libldb-devel < 1.1.0-3
66
67 %description devel
68 Header files needed to develop programs that link against the LDB
69 library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
73 bibliotekę LDB.
74
75 %package -n python-ldb
76 Summary:        Python bindings for the LDB library
77 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LDB
78 Group:          Libraries/Python
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       python-libs >= 1:2.4.2
81 Requires:       python-tdb >= %{tdb_version}
82 Obsoletes:      pyldb
83
84 %description -n python-ldb
85 Python bindings for the LDB library.
86
87 %description -n python-ldb -l pl.UTF-8
88 Wiązania Pythona do biblioteki LDB.
89
90 %package -n python-ldb-devel
91 Summary:        Development files for the Python bindings for the LDB library
92 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do biblioteki LDB
93 Group:          Development/Libraries
94 Requires:       python-ldb = %{version}-%{release}
95
96 %description -n python-ldb-devel
97 Development files for the Python bindings for the LDB library.
98
99 %description -n python-ldb-devel -l pl.UTF-8
100 Pliki programistyczne wiązań Pythona do biblioteki LDB.
101
102 %prep
103 %setup -q
104
105 %build
106 CC="%{__cc}" \
107 CFLAGS="%{rpmcflags}" \
108 LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
109 PYTHONDIR=%{py_sitedir} \
110 ./configure \
111         --prefix=%{_prefix} \
112         --libdir=%{_libdir} \
113         --with-modulesdir=%{_libdir}/ldb/modules \
114         --with-privatelibdir=%{_libdir}/ldb \
115         --bundled-libraries=NONE \
116         --disable-rpath \
117         --disable-rpath-install
118
119 %{__make} \
120         V=1
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 # Shared libraries need to be marked executable for
128 # rpmbuild to strip them and include them in debuginfo
129 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   -n python-ldb -p /sbin/ldconfig
138 %postun -n python-ldb -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libldb.so.1
144 %dir %{_libdir}/ldb
145 %dir %{_libdir}/ldb/modules
146 %dir %{_libdir}/ldb/modules/ldb
147 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
148
149 %files tools
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_bindir}/ldbadd
152 %attr(755,root,root) %{_bindir}/ldbdel
153 %attr(755,root,root) %{_bindir}/ldbedit
154 %attr(755,root,root) %{_bindir}/ldbmodify
155 %attr(755,root,root) %{_bindir}/ldbrename
156 %attr(755,root,root) %{_bindir}/ldbsearch
157 %attr(755,root,root) %{_libdir}/ldb/libldb-cmdline.so
158 %{_mandir}/man1/ldbadd.1*
159 %{_mandir}/man1/ldbdel.1*
160 %{_mandir}/man1/ldbedit.1*
161 %{_mandir}/man1/ldbmodify.1*
162 %{_mandir}/man1/ldbrename.1*
163 %{_mandir}/man1/ldbsearch.1*
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libldb.so
168 %{_includedir}/ldb_module.h
169 %{_includedir}/ldb_handlers.h
170 %{_includedir}/ldb_errors.h
171 %{_includedir}/ldb_version.h
172 %{_includedir}/ldb.h
173 %{_pkgconfigdir}/ldb.pc
174 %{_mandir}/man3/ldb.3*
175
176 %files -n python-ldb
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
180 %attr(755,root,root) %{py_sitedir}/ldb.so
181
182 %files -n python-ldb-devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libpyldb-util.so
185 %{_includedir}/pyldb.h
186 %{_pkgconfigdir}/pyldb-util.pc
This page took 0.43139 seconds and 4 git commands to generate.