]> git.pld-linux.org Git - packages/lcms.git/blob - lcms.spec
- release 5
[packages/lcms.git] / lcms.spec
1 #
2 # Conditional build:
3 %bcond_without  python  # don't build python bindings
4 #
5 Summary:        Little CMS - a library to transform between colour profiles
6 Summary(pl.UTF-8):      Little CMS - biblioteka do konwersji między profilami kolorów
7 Name:           lcms
8 Version:        1.18
9 Release:        5
10 License:        MIT
11 Group:          Libraries
12 # corrupted
13 #Source0:       http://dl.sourceforge.net/lcms/%{name}-%{version}.tar.gz
14 Source0:        http://www.littlecms.com/%{name}-%{version}.tar.gz
15 # Source0-md5:  9f908e2dc48f76db77ac35a382e394c7
16 Patch0:         %{name}-python.patch
17 URL:            http://www.littlecms.com/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake >= 1:1.7.2
20 BuildRequires:  dos2unix
21 BuildRequires:  libjpeg-devel
22 BuildRequires:  libstdc++-devel
23 BuildRequires:  libtiff-devel
24 BuildRequires:  libtool >= 1:1.4.2-9
25 BuildRequires:  sed >= 4.0
26 %if %{with python}
27 BuildRequires:  python-devel >= 2.2
28 BuildRequires:  python-modules
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  swig-python >= 1.3.30
31 %endif
32 BuildRequires:  zlib-devel
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # There is no pretty description in source archive... use these.
36
37 %description
38 lcms does not allow to write profiles, and profile manipulation is not
39 its goal. Instead, lcms focus on implement fast transforms between
40 profiles.
41
42 %description -l pl.UTF-8
43 lcms nie pozwala na tworzenie profili i obróbka profili nie jest celem
44 tej biblioteki. Natomiast lcms skupia się na implementacji szybkiej
45 konwersji między profilami.
46
47 %package devel
48 Summary:        Little CMS - header files and developer's documentation
49 Summary(pl.UTF-8):      Little CMS - pliki nagłówkowe i dokumentacja
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files needed to compile programs with liblcms and some
55 documentation useful for programmers.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe potrzebne do konsolidacji z liblcms oraz dokumentacja
59 dla programistów.
60
61 %package static
62 Summary:        Little CMS - static library
63 Summary(pl.UTF-8):      Little CMS - biblioteka statyczna
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static version of liblcms.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka liblcms.
72
73 %package progs
74 Summary:        Example and demonstration programs for Little CMS
75 Summary(pl.UTF-8):      Programy przykładowe i demonstracyjne do Little CMS
76 Group:          Applications/Graphics
77 Requires:       %{name} = %{version}-%{release}
78
79 %description progs
80 Example and demonstration programs for Little CMS.
81
82 %description progs -l pl.UTF-8
83 Programy przykładowe i demonstracyjne do Little CMS.
84
85 %package -n python-lcms
86 Summary:        Little CMS module for Python
87 Summary(pl.UTF-8):      Moduł Little CMS dla Pythona
88 Group:          Libraries/Python
89 Requires:       %{name} = %{version}-%{release}
90 %pyrequires_eq  python
91
92 %description -n python-lcms
93 Little CMS module for Python.
94
95 %description -n python-lcms -l pl.UTF-8
96 Moduł Little CMS dla Pythona.
97
98 %prep
99 %setup -q
100 dos2unix configure.ac
101 %patch0 -p1
102
103 %build
104 # rebuild using newer swig (needed for g++ 4/python 2.5)
105 cd python
106 rm -f lcms.py lcms_wrap.cxx
107 swig -python -c++ -I../include lcms.i
108 cd ..
109 %{__libtoolize}
110 %{__aclocal}
111 %{__autoconf}
112 %{__automake}
113 %configure \
114         --with%{!?with_python:out}-python
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 install samples/{icctrans,wtpt} tifficc/tifficc $RPM_BUILD_ROOT%{_bindir}
125
126 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{a,la}
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS COPYING NEWS README.1ST
137 %attr(755,root,root) %{_libdir}/liblcms.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/liblcms.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc doc/*
143 %attr(755,root,root) %{_libdir}/liblcms.so
144 %{_libdir}/liblcms.la
145 %{_includedir}/*.h
146 %{_pkgconfigdir}/lcms.pc
147
148 %files static
149 %defattr(644,root,root,755)
150 %{_libdir}/liblcms.a
151
152 %files progs
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_bindir}/*
155 %{_mandir}/man1/*.1*
156
157 %if %{with python}
158 %files -n python-lcms
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{py_sitedir}/_lcms.so
161 %{py_sitedir}/lcms.py
162 %endif
This page took 0.044717 seconds and 4 git commands to generate.